LINUX.ORG.RU

При подключенной USB камре пропадает интернет


0

0

ПК подключается к интернету через USB модем, через некоторое время прекращается передача данных, хотя интерфейс ррр поднят. Если видеокамеру отключить, то все работает нормально, связь не пропадает. Подскажите, где смотреть, в чем может быть проблема? Спасибо!


Покажи вывод следующих команд:

uname -a
dmesg
lsusb -v
lspci -vnn
Выложи на какой-нибудь пастебин.

Deleted ()

Вообще, в качестве пробной версии (какой вопрос, такой и ответ) могу предложить поискать в BIOS настройку типа «Legacy USB storage detect» и поставить ее в «Disabled». Была у меня проблема, работал либо iPod, либо HID-мышь. Как только выключил это, сразу все нормально стало.

ostin ★★★★★ ()
Ответ на: комментарий от ostin

ОК! Попробую. Вот, только устройства работают нормально. После поднятия линка, 5-10 минут все отлично, потом интернет пропадает.

alg ()
Ответ на: комментарий от Deleted

Сегодня выложу результаты выполнения команд. У меня закралось такое подозрение, что сбой происходит по причине нахождения камеры и модема на одном прерывании. Когда идет захват изображения с камеры (получаем снимок и сохраняем на диск), то пинги проходят с большой задержкой, а серия снимков приводит к отваливанию интернета. Какие соображения по этому поводу будут?

alg ()
Ответ на: комментарий от alg

У меня закралось такое подозрение, что сбой происходит по причине нахождения камеры и модема на одном прерывании. Когда идет захват изображения с камеры (получаем снимок и сохраняем на диск), то пинги проходят с большой задержкой, а серия снимков приводит к отваливанию интернета. Какие соображения по этому поводу будут?

По идее весь USB-контроллер висит на одном прерывании и это нормально. А проблема может быть в чём угодно: от ошибки в линуксовом драйвере контроллера до нехватки питания на USB-портах.

Deleted ()
Ответ на: комментарий от Deleted

Для информации - это одноплатный чудо-компьютер от Gemotech, SBC-3662 AMD LX800

alg ()
Ответ на: комментарий от Deleted

Просадок ни по току ни по напряжению нет. Эта же ОС на нормальной материнке, где присутствует несколько USB hub все работает нормально, без проблем.

alg ()

Проблему решили. Спаяли переходник PC/104+ => PCI воткнули карточку с USB портами и все заработало. Похоже встроенный контролер не справлялся с двумя устройствами, которые требовали полного доступа.

alg ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.