LINUX.ORG.RU

Не записывается/захватывается звук


0

0

У меня вопрос к сообществу! Имеется звуковая карточка. Звук всегда работал. Но вот захотелось использовать аудикарточку в качкстве АЦП и оказалось что мой Debian/testing отказывается «захватывать» звук. То есть я даже не могу записать звук идущий, например, с приемника на линейный/микрофонный вход звуковой карточки, но при этом я его слышу на выходе и громкость регулируется. Если кто знает, помогите плиз! Система: Debian/testing Ядро: 2.6.32 arecord --list-device **** List of CAPTURE Hardware Devices **** card 0: SB [HDA ATI SB], device 0: ALC262 Analog [ALC262 Analog] Subdevices: 1/1 Subdevice #0: subdevice #0 Таким образом, все ползунки в alsamixer активны, и в секции capture, но запись не идет. один шум. я его слышу на выходе линейном, но системой он как-то не захватывается

нужны права на какие-то устройства типа /dev/dsp или что-то в этом роде или включить себя в какую-то группу. Короче все дело в нехватке прав. Я так думаю.

ansky ★★★★★ ()
Ответ на: комментарий от ansky

Я уже все вроде делал, и права устанавливал (и под рутом пробовал), alsa-модули последние ставил, все равно ВСЁ одно и тоже даже не меняется ничего, только версии ПО и драйверов меняются. Не ужели такое спецефическое оборудование? Вот еще один лог:

zomax@kotik:~$ cat /dev/sndstat Sound Driver:3.8.1a-980706 (ALSA v1.0.22.1 emulation code) Kernel: Linux kotik 2.6.32-zomax-build #1 SMP Sat Dec 5 19:39:17 EET 2009 x86_64 Config options: 0

Installed drivers: Type 10: ALSA emulation

Card config: HDA ATI SB at 0xd8300000 irq 16

Audio devices: 0: ALC262 Analog (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers: 7: system timer

Mixers: 0: Realtek ALC262

Кто что посоветует?

maxastro ()

Ура, разобрлся. Оказалось, по умолчанию загружался не тот модуль snd-hda-intel. При выгрузке всех приложений работающих со звуком (команда: lsof /dev/snd/*, команда: kill), выгрузки модуля (команда: modprobe -r snd-hda-intel) и загрузки нового модуля (команда: modprobe snd-hda-intel model=basic) все заработало как надо. Решение подсмотрел после неудачных попыток самостоятельо решить проблему, путем синтеза Убунтофорумс и генту-форум

maxastro ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.