LINUX.ORG.RU

USB Mass Storage перестал моунтится


0

0

Уважаемые гуру,

с недавнего времени меня имеет проблема неподсоединения моей флешки. Раньше всё было нормально. Работало на всех системах. Теперь работает только на венде...
Есть подозрения, что перед тем как флешка перестала подсоединяться, она была вытащена без umount из порта.
Итак, сейчас происходит следующее:
1. как только вставляю в порт, dmesg выводит

usb 5-5: new high speed USB device using ehci_hcd and address 8
usb 5-5: configuration #1 chosen from 1 choice
hub 5-5:1.0: USB hub found
hub 5-5:1.0: 1 port detected
usb 5-5.1: new high speed USB device using ehci_hcd and address 9
usb 5-5.1: configuration #1 chosen from 1 choice
scsi5 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 9
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 5:0:0:0: Direct-Access Corsair Flash Voyager 1.00 PQ: 0 ANSI: 0 CCS
sd 5:0:0:0: [sdb] 4005888 512-byte hardware sectors (2051 MB)
sd 5:0:0:0: [sdb] Write Protect is off
sd 5:0:0:0: [sdb] Mode Sense: 00 26 00 00
sd 5:0:0:0: [sdb] Assuming drive cache: write through
sd 5:0:0:0: [sdb] 4005888 512-byte hardware sectors (2051 MB)
sd 5:0:0:0: [sdb] Write Protect is off
sd 5:0:0:0: [sdb] Mode Sense: 00 26 00 00
sd 5:0:0:0: [sdb] Assuming drive cache: write through

2. Вроде всё ничего, но потом:
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
end_request: I/O error, dev sdb, sector 0
printk: 4 messages suppressed.
Buffer I/O error on device sdb, logical block 0
hub 5-5:1.0: hub_port_status failed (err = -71)
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
end_request: I/O error, dev sdb, sector 0
Buffer I/O error on device sdb, logical block 0
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
end_request: I/O error, dev sdb, sector 0
Buffer I/O error on device sdb, logical block 0
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
end_request: I/O error, dev sdb, sector 0
Buffer I/O error on device sdb, logical block 0
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
end_request: I/O error, dev sdb, sector 0
Buffer I/O error on device sdb, logical block 0
ldm_validate_partition_table(): Disk read failed.
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
end_request: I/O error, dev sdb, sector 0
Buffer I/O error on device sdb, logical block 0
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
end_request: I/O error, dev sdb, sector 0
Buffer I/O error on device sdb, logical block 0
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
end_request: I/O error, dev sdb, sector 0
Buffer I/O error on device sdb, logical block 0
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
end_request: I/O error, dev sdb, sector 0
Buffer I/O error on device sdb, logical block 0
Dev sdb: unable to read RDB block 0
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
end_request: I/O error, dev sdb, sector 0
Buffer I/O error on device sdb, logical block 0
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
end_request: I/O error, dev sdb, sector 0
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
end_request: I/O error, dev sdb, sector 24
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
end_request: I/O error, dev sdb, sector 24
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
end_request: I/O error, dev sdb, sector 0
unable to read partition table
sd 4:0:0:0: [sdb] Attached SCSI removable disk
sd 4:0:0:0: Attached scsi generic sg2 type 0
sd 4:0:0:0: [sdb] READ CAPACITY failed
sd 4:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
sd 4:0:0:0: [sdb] Sense not available.
sd 4:0:0:0: [sdb] Write Protect is off
sd 4:0:0:0: [sdb] Mode Sense: 00 00 00 00
sd 4:0:0:0: [sdb] Assuming drive cache: write through


после чего последние 9 строчек бесконечно выплёвываются в лог.
что подскажите?

Re: USB Mass Storage перестал моунтится

А на флешке нет каталога DCMI или каке то так? У меня было такое и с флешкой и с фотиком, раскопал что HAL при нахождении сего каталога хочет примаунтить флешку через libphoto2 и пытается использовать свой протокол... Лечится удалением с /usr/share/hal всего связанного libphoto2

SilentLexx ()

Re: USB Mass Storage перестал моунтится

А если вручную монтировать - какие сообщения выдаются?

garikello ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.