LINUX.ORG.RU

suse10.3 звук на ноуте


0

0

Здравствуйте!

у меня ноутбук HP Pavilion dv9000 в сусе 10.3 не работает звук.
ни в амароке ни в кде. микшер крутил, движок в амароке менял с гстример на ксайн и обратно, в кде движок менял на альса Jack, OSS и т.д - всеравно не работает..
Хотя при загрузке линукса из динамиков вроде слышится тестовый щелчок.

что посоветуете?

# lsmod | grep snd
snd_seq_dummy 20100 0
snd_pcm_oss 62720 0
snd_mixer_oss 32384 1 snd_pcm_oss
snd_seq 66740 1 snd_seq_dummy
snd_seq_device 24460 2 snd_seq_dummy,snd_seq
snd_hda_intel 285212 7
snd_pcm 94852 4 snd_pcm_oss,snd_hda_intel
snd_timer 39044 4 snd_seq,snd_pcm
snd 70452 18 snd_seq_dummy,snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,sn d_pcm,snd_timer
soundcore 23748 1 snd
snd_page_alloc 26248 2 snd_hda_intel,snd_pcm

★★

Re: suse10.3 звук на ноуте

Вообщем у меня чип оказывается ALC268 для него плохая поддержка в ALSA

поставил последние ALSA 2.0.16

настраивал звук по этому мануалу - https://help.ubuntu.com/community/HdaIntelSoundHowto
и также по этому http://www.linux.org.ru/view-message.jsp?msgid=2539631&lastmod=1204957556988

пробывал различные записи в /etc/modprobe.d/sound, гуглил, снова пробывал и т.д. ничего не выходит - звука нет (хотя амарок проигрывает - просто ничего не слышно)


беда в том что у меня для моего чипа ALC268 в моём кернеле от суси 2.6.22 в
/usr/src/linux/Documentation/sound/alsa/ALSA-Configuration.txt
прописаны только два модуля - auto и 3stack (и ниодин из них не заводит звук)
НО! например для ядра 2.6.24 таких моделей несколько - auto, 3stack, toshiba, acer - http://www.mjmwired.net/kernel/Documentation/sound/alsa/ALSA-Configuration.txt

вопрос -
1. чтобы добавить моделей с альсы обязательно ставить последнее ядро? 2. почему не достаточно поставить последнюю ALSA?

(советы типа погоняй бегунки на микшере масдай)

dmesg рестарта /etc/init.d/alsasound:
ACPI: PCI interrupt for device 0000:00:1b.0 disabled
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 22 (level, low) -> IRQ 23
PCI: Setting latency timer of device 0000:00:1b.0 to 64
ALSA sound/pci/hda/hda_codec.c:1802: hda_codec: model 'auto' is selected
ALSA sound/pci/hda/hda_codec.c:2331: autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2335: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2339: hp_outs=1 (0x15/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2347: inputs: mic=0x18, fmic=0x19, line=0x0, fline=0x0, cd=0x0, aux=0x0

почемуто после установки последней альсы 2.0.16 на рестарте alsasound стала появляться такая ошибка
/usr/sbin/alsactl: relocation error: /usr/sbin/alsactl: symbol snd_tlv_parse_dB_info, version ALSA_0.9 not defined in file libasound.so.2 with link time reference
Shutting down sound driver done
Starting sound driver: hda-intel done

ppy ★★ ()
Ответ на: Re: suse10.3 звук на ноуте от ppy

Re: suse10.3 звук на ноуте

это конфигурация в модпроб
cat /etc/modprobe.d/sound
options snd-hda-intel enable=1 index=0 model=auto probe_mask=1 single_cmd=1
alias snd-card-0 snd-hda-intel

ppy ★★ ()
Ответ на: Re: suse10.3 звук на ноуте от ppy

Re: suse10.3 звук на ноуте

У меня ALC861. Работает с model=3stack

Попробуй, может и тебе подойдет. Попытка не пытка!

hibou ★★★★★ ()
Ответ на: Re: suse10.3 звук на ноуте от hibou

Re: suse10.3 звук на ноуте

пробывал неподходит :(
звука нет.

почему в сорцах ядра только 2 модуля?
может можно как-то увеличить? или обязательно новое ядро для этого ставить, новой альсы недостаточно ?

ppy ★★ ()
Ответ на: Re: suse10.3 звук на ноуте от ppy

Re: suse10.3 звук на ноуте

разобралсо - звук заработал : )

вообщем может комуто пригодится
у меня сусе 10.3

я зашел на http://software.opensuse.org/search
там нашел пакет для кернела c драйверами от новой альсы
alsa-driver-kmp-bigsmp
alsa-driver-kmp-doc

установил и рестартонулся
затем в /etc/modprobe.d/sound написал
options snd-hda-intel enable=1 index=0 model=zepto
(c model=toshiba тоже зарабатло)

перегруз /etc/init/alsasound restart

и звук заработал :)
всем спасибо!

ppy ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.