LINUX.ORG.RU

CentOS, не грузится ядро.


0

0

Здравствуйте!
Ситуация такова. Сервер стоит далеко и за границей. Я этот сервак в глаза не видел, и даже наверняка не знаю, что за материнская плата используется. На нем установлена CentOS 5.1 с ядром, которое собрано конторой, у которой этот сервер и установлен. При этом ядро не модульное, все драйвера вкомпилированы в ядро и с него всё грузится.
Что удалось узнать:
1. По версии BIOS (PRG3110H.86A) - это вроде как материнка Intel Desktop Board DG31PR на чипсете Intel G31 Express Chipset.
2. Вот список устройств:
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
3. Жёсткие диски Hitachi HDS72107, подключены к SATA.

Добавил в /etc/modprobe.conf:
alias eth0 r8169
alias scsi_hostadapter ata_piix

Установил стандартное ядро от CentOS. Посмотрел в initrd все нужные для загрузки драйвера вроде есть:
ata_piix.ko
ehci-hcd.ko
ext3.ko
jbd.ko
libata.ko
ohci-hcd.ko
scsi_mod.ko
sd_mod.ko
uhci-hcd.ko

Но вот грузиться Linux с эти ядром от CentOS не хочет, и при этом я даже не знаю, что происходит (сервер далеко, то что происходит на мониторе нет возможности увидеть).
Параметры загрузки:
title CentOS (2.6.18-53.1.4.el5)
root (hd0,0)
kernel /vmlinuz-2.6.18-53.1.4.el5 ro root=/dev/sda2 ide0=noprobe ide1=noprobe nodmraid
initrd /initrd-2.6.18-53.1.4.el5.img

Без noprobe и nodmraid так же не грузится. Ядро от хостера, грузится нормально с такими же параметрами:
title Linux (2.6.22.1)
root (hd0,0)
kernel /bzImage-2.6.22.1 ro root=/dev/sda2 ide0=noprobe ide1=noprobe nodmraid

Так же не работает возможность удалённой установки CentOS, видимо тоже происходит какой-то сбой во время загрузки ядра.

Что можно ещё сделать/посмотреть? Может быть у кого-то есть машинка с CentOS и с такой же матерью и есть возможность проверить удалённую установку. Или кто-то знает, что нужно ещё добавить в конфигурацию, в параметры загрузки ядра?

anonymous

Ответ на: Re: CentOS, не грузится ядро. от anonymous

Re: CentOS, не грузится ядро.

Именно это и имелось в виду. Может на матери есть какие-нибудь средства аппаратной удалённой консоли? IPMI тот же, например.

Kuzmich ★★ ()

Re: CentOS, не грузится ядро.

Посадить аборигена с цифровиком перед монитором и заставить фотографировать и слать фоты.

INFOMAN ★★★★★ ()
14 января 2008 г.

Re: CentOS, не грузится ядро.

столкнулся похожей проблемой, материнка Intel DG33FB + Core Duo + 4 Gb При попытке установки Centos (от 4.4 до 5.1) машина висла. При этом Ubuntu нормально запускается и ставится. Проблему с инсталляцией CentOS обошел запуском инсталляции в текстовом режиме. Однако после инсталляции - Иксы не стартуют - машина виснет, пляски с БИОСом ни к чему не привели. БИОС тоже обновил. Проблему с запуском иксов пока обошел, воткнув видяху в PCI слот. Поскольку машинка будет серваком, то насчет работоспособности иксов не переживаю. Тем не менее - получается что 82G33/G31 Express Integrated Graphics Controller не работоспособен под CentOS. В багтраке центоса ничего про это нету, но на форуме такие проблемы есть: http://www.centos.org/modules/newbb/search.php - ищем G33 add Обошел следующим образом, вытащил ATI, запустил реконфигурацию иксов: setup - настройка X. Оно ругнулось, что видяха не та и типа сбросила установки, нашла встроенный адаптер, после этого иксы заработали нормально.

nempyxa ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.