LINUX.ORG.RU

Нужно найти конфиг для сетевого интерфейса чипа Allwinner H618

 , ,


0

3

Здравствуйте! У чипа Allwinner H618 проводной езернет идёт прямо с чипа(SoC). В распоряжении андроид 5.4 ядро с рутом, есть конфиг ядра андроида. Есть ДТБ от андроида. Аппаратно езернет работает штатно. Нужно узнать, какой конфиг нужен, чтобы в 6.6 и старше ядре линукс получить рабочую проводную сеть.

В ДТБ андроида:

eth@5030000 {
                        compatible = "allwinner,sunxi-gmac";
                        reg = <0x00 0x5030000 0x00 0x10000 0x00 0x3000034 0x00 0x04>;
                        interrupts = <0x00 0x0f 0x04>;
                        interrupt-names = "gmacirq";
                        clocks = <0x02 0x55>;
                        clock-names = "gmac";
                        resets = <0x02 0x20>;
                        device_type = "gmac1";
                        phy-mode = "rmii";
                        phy-rst;
                        gmac-power0;
                        gmac-power1;
                        gmac-power2;
                        status = "okay";
                        pinctrl-0 = <0x5d>;
                        pinctrl-1 = <0x5e>;
                        pinctrl-names = "default\0sleep";
                        tx-delay = <0x07>;
                        rx-delay = <0x1f>;
                        phandle = <0xbc>;
                };
Вроде как бы gmac искать надо, но в конфиге ядра 5.4 андроид не находится совпадений. Возможно, что есть способ с андроида узнать, что за драйвер используется.

Надеюсь на поддержку.

★★★★★

Ответ на: комментарий от burato

Просто на сайте linux-sunxi писали что:

Mali 3D: should work with Panfrost, but need (simple) power domain driver to toggle one bit

Я пока что протестировал только armbian bookworm для Orange Pi Zero 3 на Orange Pi Zero 2W, там panfrost работает. Когда приобрету новую карту памяти (текущая уже еле-работает), попробую собрать mainline linux и попытать счастье свалить хотя-бы на devuan.

Goat ★★
()
Ответ на: комментарий от mittorn

И даже если allwinner,sunxi-gmac в ядре есть, не факт что dts от вендорского 5.4 совместим с драйвером в апстриме. Такое тоже вполне может быть, на многие драйверы лежит схема в yaml файле с которой можно свериться скриптом.

a1ba ★★
()