LINUX.ORG.RU

Модем USR 56k (int) - проблемы с подключением


0

0

Ввиду того, что у меня не получается скомпилить ltmodem-8.31a10 под 2.6.15.6 gcc 3.4.5 решил установить вместо него валяющийся уже с полгода в ящике аппаратный USR.

выползло две проблемы 1) Он соединяется на скорости 21-26 Kb/s 2) Он не соединяется.

По пунктам: При ответе он начинает петь обычную песенку на 56k, посреди её резко обрывается и начинает свистеть новую (такой я не слышал), после говорит, CONNECT 24000; v34; v42 и ещё что-то в этом духе. После пары секунд сбрасывает - в логах "loopback detected". pppd - error 17.

Не так ведёт себя софтовый LT-момед. Он нормально соединяется на v90, 49-56 Kb/s (линия хорошая, АТС цифровая), обычно после CONNECT до минуты обменивается инфой с сервером, дальше всё нормально.

вопросы: 1. как заставить модем соединяться на нормальной скорости (судя по манам, это должно быть указано в инструкции к модему, которой отродясь не было) 2. Как заставить его соединяться?

anonymous

Re: Модем USR 56k (int) - проблемы с подключением

с аппаратным можно поиграться со скоростью порта.

>После пары секунд сбрасывает - в логах "loopback detected". pppd - error 17.

намудрил со скриптами/настройками звонилки. чем звоним вообще?

для люкмодема на новых ядрах нужно искать такую штуку: ltmodem-2.6-alk-8.tar.bz2.

http://linuxforum.ru/index.php?showtopic=15699&hl=

Muromec ☆☆ ()
Ответ на: Re: Модем USR 56k (int) - проблемы с подключением от Muromec

Re: Модем USR 56k (int) - проблемы с подключением

>с аппаратным можно поиграться со скоростью порта.

Максимальная стоит.

$ setserial -a /dev/ttyS2 /dev/ttyS0, Line 0, UART: 16550A, Port: 0x03f8, IRQ: 11 Baud_base: 115200, close_delay: 500, divisor: 0 closing_wait: 30000 Flags: spd_normal skip_test

У самого модема есть какие-то настройки (нашёл пдф-ку с инструкцией)

для люкмодема на новых ядрах нужно искать такую штуку: ltmodem-2.6-alk-8.tar.bz2.

tnx, отыскал. буду пробовать.

anonymous ()
Ответ на: Re: Модем USR 56k (int) - проблемы с подключением от Muromec

Re: Модем USR 56k (int) - проблемы с подключением

мля, ещё раз
>с аппаратным можно поиграться со скоростью порта.

Максимальная стоит.

$ setserial -a /dev/ttyS2
/dev/ttyS0, Line 0, UART: 16550A, Port: 0x03f8, IRQ: 11
        Baud_base: 115200, close_delay: 500, divisor: 0
        closing_wait: 30000
        Flags: spd_normal skip_test


У самого модема есть какие-то настройки (нашёл пдф-ку с инструкцией)

для люкмодема на новых ядрах нужно искать такую штуку: ltmodem-2.6-alk-8.tar.bz2.

tnx, отыскал. буду пробовать.

anonymous ()
Ответ на: Re: Модем USR 56k (int) - проблемы с подключением от Muromec

Re: Модем USR 56k (int) - проблемы с подключением

>намудрил со скриптами/настройками звонилки. чем звоним вообще?

Ничего не мудрил. kppp с дефолтовыми настройками.

Кстати, может причина здесь - девайс версии 3CP2976-OEM, теоретически - Канадская версия.

anonymous ()
Ответ на: Re: Модем USR 56k (int) - проблемы с подключением от Muromec

Re: Модем USR 56k (int) - проблемы с подключением

Итого:

USR будет настроение - помучаю.

Рабочие драйвера для Lucent/Agere:

http://linmodems.technion.ac.il/packages/ltmodem/kernel-2.6/ltmodem-2.6-alk-8...

Только что скомпилил и запустил - всё работает

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.