LINUX.ORG.RU

Audigy +debian


0

0

ну уже ничего не помогает, модпробе что пишет: Sklep:/lib# modprobe emu10k1 /lib/modules/2.4.27-2-386/kernel/drivers/sound/emu10k1/emu10k1.o: init_module: No such device Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg /lib/modules/2.4.27-2-386/kernel/drivers/sound/emu10k1/emu10k1.o: insmod /lib/modules/2.4.27-2-386/kernel/drivers/sound/emu10k1/emu10k1.o failed /lib/modules/2.4.27-2-386/kernel/drivers/sound/emu10k1/emu10k1.o: insmod emu10k1 failed

и что отвечает lspci Sklep:/lib# lspci 0000:00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host Bridge (rev 04) 0000:00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge (rev 04) 0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 05) 0000:00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 05) 0000:00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 05) 0000:00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 05) 0000:00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 05) 0000:00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 05) 0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 If [Radeon 9000] (rev 01) 0000:02:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10) 0000:02:03.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03) 0000:02:03.1 Input device controller: Creative Labs SB Audigy MIDI/Game port (rev 03) 0000:02:03.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port 0000:02:04.0 Network controller: AIRONET Wireless Communications PC4800 (rev 01)0000:02:05.0 Multimedia audio controller: Fortemedia, Inc Xwave QS3000A [FM801] (rev b2) 0000:02:05.1 Input device controller: Fortemedia, Inc Xwave QS3000A [FM801 game port] (rev b2) 0000:02:0a.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 04 если что-то ещё нужно скажите

anonymous

Re: Audigy +debian

Может стоит поставить ALSA?

sabonez ★☆☆☆ ()
Ответ на: Re: Audigy +debian от sabonez

Re: Audigy +debian

Скажи точно модель звуковухи.
ЗЫ. С какой радости ты OSS-ный модуль грузишь, надо бы
modprobe snd-emu10k1

sabonez ★☆☆☆ ()
Ответ на: Re: Audigy +debian от sabonez

Re: Audigy +debian

>Скажи точно модель звуковухи. ЗЫ. С какой радости ты OSS-ный модуль грузишь, надо бы modprobe snd-emu10k1

Это не важно, должны оба модуля подгружаться и нормально работать. Другое дело, что скорее всего надо грузить другой модуль, а именно:

ca0106 или snd-ca0106. Насколько помню, поддержка есть в ядрах начиная с 2.6.8, может даже с более поздних - уточнить сейчас нет возможности.

Подробнее можно как всегда глянуть на сайте альсы: http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=Creative+La...

kvit ()
Ответ на: Re: Audigy +debian от kvit

Re: Audigy +debian

>>Это не важно, должны оба модуля подгружаться и нормально работать.
Ну, не факт. ;-)
>>ca0106 или snd-ca0106.
Дык вот я и спрашивал про точную модель.
Если LS - то да, надо ca0106. Тока он появился в алсе, начиная с 1.0.9 по-моему.

Да, а еще помнится на 2.4 надо какой то скриптик запускать было - snddevices вроде.

sabonez ★☆☆☆ ()

Re: Audigy +debian

у тебя ядро 2.4.27? на дебиане же есть ядро 2.6.8-12. пользуй его. у меня это ядро грузится и модуль emu10k1 загружается без проблем и отлично работает.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.