LINUX.ORG.RU

pppd & kernel 2.6


0

0

Возникли проблемы с сочетанием этих двух вещей. При запуске pppd пишет, что ядро не поддерживает ppp и что нужно подгрузить модуль ppp, но я скомпилировал с полной поддержкой ppp, к тому же в ядрах выше 2.6 нет модуля ppp, есть только ppp_generic. В документации к pppd описана только работа с ядрами не выше 2.4. Версия pppd - самая новая, что была в портаже -- какая, не помню -- пишу с другого компа.

В чем может быть проблема?

anonymous

Re: pppd & kernel 2.6

У меня:
net-dialup/ppp-2.4.2-r10
В ядре:
<M> - PPP (point-to-point protocol) support
[*] - PPP multilink support
<M> - PPP support for async serial ports
<M> - PPP support for sync tty ports
<M> - PPP Deflate compression
<M> - PPP BSD-Compress compression
/etc/modiles.d
Файло назвал ppp, в нем:
alias /dev/ttyS0 8250
alias char-major-108 ppp_generic
alias /dev/ppp ppp_generic
alias tty-ldisc-3 ppp_async
alias tty-ldisc-13 n_hdlc
alias tty-ldisc-14 ppp_synctty
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate
----------------------
И все работает...

sanders ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.