LINUX.ORG.RU

Alpine не отправляет письма с кириллицей в тексте

 


0

1

Приветствую всех!

Такая проблема: почтовый клиент alpine прекрасно работал до очередного apt-get update.

После update перестали отправляться письма с кириллицей в тексте. При наличии в тексте только латиницы письма отправляются нормально.

На отправку кириллица/латиница в теме отправления не влияет.

Привожу ошибку:

[Mail not sent. Sending error: 501 <name@post.ru> BODY=8BITMIME: malformed address: BODY=8BITMIME may not follow <name@post.ru>

Что такое слетело и как с этим бороться?


А кaк alpine отправляет почту? Через локальный exim, который тоже обновился? Потому что гуглится только это http://comments.gmane.org/gmane.mail.exim.devel/5304 .

Ну можно попробовать в настройках alpine отключить опцию «Enable 8bit ESMTP Negotiation». Это должно убрать из заголовка BODY=8BITMIME и alpine будет отправлять всё в 7-бит кодировке. Возможно, это не совсем правильно, но должно помочь.

mky ★★★★★ ()
Ответ на: комментарий от mky

Нет, exim не использую. Alpine непосредственно связывается с почтовым сервером rambler.ru через мою учетную запись, забирает и отправляет почту.

Спасибо, по поводу опции «Enable 8bit ESMTP Negotiation» обязательно дома поробую и отпишусь.

nniko ()
Ответ на: комментарий от mky

Alpine Version 2.02. Нашел опцию «Enable 8bit ESMTP Negotiation». Отключил. Все отправляет.

Спасибо за подсказку!

nniko ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.