LINUX.ORG.RU

Gentoo/Linux Calculate + Linux Standard Base — что можно сделать?

 , , ,


0

1

Проблема - для работы FLEXlm License Manager требуется Linux Standard Base (LSB)
http://software.intel.com/en-us/articles/lmgrd-no-such-file-or-directory
http://software.intel.com/en-us/articles/flexlm-license-manager-20-may-fail-w...

А на License Manager завязано несколько важных для меня программ (по разработке под FPGA).
Есть ли шансы запустить это дело под Gentoo/Linux Calculate и если да - то как? :)

P.S. На Gentoo только пересел, пока осваиваюсь.


Убери тэг fpga, он тут совершенно не нужен.

olibjerd ★★★★★ ()
Ответ на: комментарий от elrprt

Во первых

grep etc $(whereis lsb_release)

во вторых

cat /etc/gentoo-release

а в третьих емнип и сам flexlm в генте был и если что кучи программ которые зависят от sys-apps/lsb-release в портежах тоже есть(т.е. как то оно работает).

init_6 ★★★★★ ()
Ответ на: комментарий от init_6
#grep etc $(whereis lsb_release)
grep: lsb_release:: No such file or directory
/usr/bin/lsb_release:# - LSB_VERSION is no longer required in /etc/lsb-release file
/usr/bin/lsb_release:# Collect informations from sourceable /etc/lsb-release file (present on
/usr/bin/lsb_release:# Then (if needed) find and parse the /etc/[distro]-release file.
/usr/bin/lsb_release:INFO_ROOT="/etc"                              # directory of config files
/usr/bin/lsb_release:ALTERNATE_DISTRIB_FILE="/etc/debian_version"  # for Debian [based distrib]
/usr/bin/lsb_release:CHECKFIRST="/etc/redhat-release"              # check it before file search
/usr/bin/lsb_release:    NO=""  # /etc/lsb-release data are enough to reply what is requested? 
#cat /etc/gentoo-release
Calculate Linux Desktop 13.4 KDE

Есть еще некоторый шанс, что проблема может быть не только в LSB, но все отзывы, которые гуглил - отправляют копать именно в его сторону.

Вот еще последствия emerge

#emerge lsb-release
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-apps/lsb-release-1.4
 * lsb-release-1.4.tar.gz SHA256 size ;-) ...                                                                                                                                [ ok ]
>>> Unpacking source...
>>> Unpacking lsb-release-1.4.tar.gz to /var/calculate/tmp/portage/sys-apps/lsb-release-1.4/work
>>> Source unpacked in /var/calculate/tmp/portage/sys-apps/lsb-release-1.4/work
 * Package net-misc/gwibber specified in the merge() into /var/lib/layman/calculate/profiles/templates/3.1/6_ac_install_patch/net-misc/gwibber/.calculate_directory template is not found
>>> Compiling source in /var/calculate/tmp/portage/sys-apps/lsb-release-1.4/work/lsb-release-1.4 ...
make -j9 
>>> Source compiled.
>>> Test phase [not enabled]: sys-apps/lsb-release-1.4

>>> Install lsb-release-1.4 into /var/calculate/tmp/portage/sys-apps/lsb-release-1.4/image/ category sys-apps
make -j9 prefix=/var/calculate/tmp/portage/sys-apps/lsb-release-1.4/image//usr mandir=/var/calculate/tmp/portage/sys-apps/lsb-release-1.4/image//usr/share/man install 
install -D -m 644 lsb_release.1.gz /var/calculate/tmp/portage/sys-apps/lsb-release-1.4/image//usr/share/man/man1/lsb_release.1.gz
install -D -m 755 lsb_release /var/calculate/tmp/portage/sys-apps/lsb-release-1.4/image//usr/bin/lsb_release
>>> Completed installing lsb-release-1.4 into /var/calculate/tmp/portage/sys-apps/lsb-release-1.4/image/

ecompressdir: bzip2 -9 /usr/share/man

>>> Installing (1 of 1) sys-apps/lsb-release-1.4
 * Package dev-db/desktopcouch specified in the merge() into /var/lib/layman/calculate/profiles/templates/3.1/2_ac_install_merge/dev-db/desktopcouch/.calculate_directory template is not found
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

 * IMPORTANT: config file '/etc/timezone' needs updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
elrprt ()

Я, находясь в подобной ситуации, поставил всю проприетарщину на виртуалку с Debian (а лучше было бы взять что-нибудь официально поддерживаемое, вроде CentOS). Во-первых, не хочу пускать эту мерзкую проприетарщину в основную систему, во-вторых — нет описанных проблем с совместимостью и версиями библиотек.

Только у меня софт для разработки не на FPGA, а на чистом кремнии :) И я боюсь, что этот финт с виртуалкой мне ещё аукнется, когда дело дойдёт до моделирования действительно тяжёлых проектов.

prozium ★★ ()
Последнее исправление: prozium (всего исправлений: 1)
Ответ на: комментарий от prozium

У меня софт, фактически, тоже под ASIC - Synplify + VCS + Cadence пакет
Просто ASIC'ами пока профессионально не занимаюсь. Все достаточно стабильно болталось на OpenSUSE, но больше Gentoo направление нравится.
Только времени разбираться пока мало :)

elrprt ()
Ответ на: комментарий от init_6

Я привел, что бы наткнувшимся на тему в дальнейшем была видна полная картина - проще решение найти будет.

elrprt ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.