LINUX.ORG.RU

Не печатает принтер после установки через Cups


0

1

Ставил юсб принтер Canon MF4018 через Cups.После установки такие параметры: Драйвер:Canon MF4010 Series UFRII LT ver.2.6 (черно-белый, дуплексная печать) Подключение:serial:/dev/ttyS0?baud=1200+bits=8+parity=none+flow=none По умолчанию:job-sheets=none, none media=iso_a4_210x297mm sides=one-sided Драйвер MF4010 подходит для MF4018(вычитал на форуме).И при попытке пробной печати через интерфейс Cups'а пишет что печатает,и печать завершена.А при попытке печати другого файла висит в заданиях отправка на печать,но не печатает.И пока не отменишь-так и будет висеть. Как исправить это?

Этот принтер использует capt драйвер, нормально завести его под Linux большие проблемы. В особенности с последними версиями cups, т.к. драйверу нужен модуль usblp, в то время как последние версии cups требуют, что бы этого модуля не было.

В общем, вам проще купить другой принтер, например какой-нибудь HP.

kostik87 ★★★★★ ()
Ответ на: комментарий от ansky

Подключение:serial:/dev/ttyS0?baud=1200+bits=8+parity=none+flow=none

Это шутка?

Какая шутка)А что должно быть там? Все дело в том,что первое время этот принтер нормально работал и печатал на ОС,которая сейчас и установлена.Но в 1 прекрасный момент все отвалилось.Не помогает переустановка принтера,обновление дров и прочее.Менять ОС очень уж неохота.

OverDozero ()
Ответ на: комментарий от ansky

через СОМ-порт со скоростью 1200 бод?

Опаньки..Мой косяк.Не приметил что подключалось на ком порт.Принтер то юсбишный... Принтер нормально работал.Может все дело в обновлении Cups?Как его подключить через юсб?Так

Для использования USB-принтера может потребоваться внести в черный список модуль usblp. Учтите, что насчет добавления usblp в черный список имеется некоторая неопределенность, так как некоторые USB-принтеры, в частности некоторые серии принтеров Canon и Epson, не определяются без этого модуля.

Взято с вики архлинукс

OverDozero ()
Ответ на: комментарий от kostik87

в то время как последние версии cups требуют, что бы этого модуля не было.

Брехня. Cups требует, чтобы, если вы конфигурируете его с usb, то в ядре не должно быть USB_PRINTER. Потому что опция usb говорит, что для общения по этой шине надо будет использовать libusb, а не модуль ядра. Читайте внимательнее.

Deleted ()
Ответ на: комментарий от Deleted

Мда, у ТС Ubuntu, у него бинарный дистрибутив, я ему и указал на эту особенность, а вам уточнил, что вы же не знаете как собран в бинарном дистрибутиве пакет, если CUPS собран с поддержкой libusb, то с ядерным модулем будут проблемы, а capt драйверу нужен как раз ядреный модуль.

kostik87 ★★★★★ ()

Всё совпадает: судя и по посту, и по нику у ТС'а передозировка.

Скажи наркотикам «Нет!»

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.