LINUX.ORG.RU

Инсталляторы не запускаются :(


0

0

У меня не запускаются ЛЮБЫЕ инсталяторы. В ответ мне пишется следущее:

$ sh tuxracer-1.1-x86.run Verifying archive integrity...tail: невозможно открыть `+6' для чтения: No such file or directory Error in check sums 656276530 109079888

И так во всех инсталяторах. Что это может быть?

★★★★

Re: Инсталляторы не запускаются :(

>Что это может быть?

Error in check sums 656276530 109079888

Selecter ★★★★
()

Re: Инсталляторы не запускаются :(

попробой из-под root

anonymous
()

Re: Инсталляторы не запускаются :(

память битая может...

anonymous
()

Re: Инсталляторы не запускаются :(

Это ж стандартная ошибка - новый tail не принимает аргументы в виде +6.
Есть два решения. 
Первый: сделать export _POSIX2_VERSION=199209 перед запуском инсталлера.

Eсли не помогло, второй: идем на ftp.gnu.org, качаем textutils-1.19.tar.gz и собираем. Там даже можно только tail собрать:
tar xzvf textutils-1.19.tar.gz && cd textutils-1.19 && ./configure && cd src && make tail
Получаем tail старого образца. Теперь делаем 
alias tail = path/to/the/tail/we/have/just/built и запускаем инсталлер

grob ★★★★★
()
Ответ на: Re: Инсталляторы не запускаются :( от grob

Re: Инсталляторы не запускаются :(

Пробовал из-под рута - тоже самое. Память хорошая. А что касается textutils, то они у меня вообще не установлены в системе. Но export _POSIX2_VERSION=199209 Мне помогло. Спасибо.

Cooler ★★★★
()
Ответ на: Re: Инсталляторы не запускаются :( от Cooler

Re: Инсталляторы не запускаются :(

>А что касается textutils, то они у меня вообще не установлены в системе

Правильно, потому что "новый" tail входит в coreutils

grob ★★★★★
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.