LINUX.ORG.RU

Задержка звука

 


0

1

Wine 1.5.14, NVIDIA.
Отключил вертикальную синхронизацию чтобы получить 100fps. Собственно, сработало, только вот звук теперь запаздывает на несколько миллисекунд. Что делать?

★★★★★

Установить Windows и не мучаться.

anonymous ()

Попробуй так:

$ pulseaudio --kill
$ pulseaudio --start
У меня иногда в Diablo 3 звук начинает, как бы это сказать, двоиться что ли. В общем, не перезапуская игры, делаю, как написал выше, и оно лечится. Может, и тебе поможет.

carasin ★★★★★ ()

А вообще, советую снести префикс Wine'а и попробовать на дефолтном (за исключением нужных для работы конкретного софта настроек, если таковые в Wine'е нужны).

carasin ★★★★★ ()
Ответ на: комментарий от AleksandrArkhipov

Потом мучаться с глюками и вирусами!

Мучаются с этим только криворучки

anonymous ()
Ответ на: комментарий от ArtKun

Хм, действительно... Нет, это я ошибся, сорри. Этот способ был актуален для старых версий вина, сейчас он используется по-умолчанию.

SummerWinds ()
Ответ на: комментарий от ArtKun

Может, так:

$ winetricks settings list | grep dsound
dsoundbug9612            Use DirectSound MaxShadowSize=0 workaround for wine bug 9612 
dsoundhw=Basic           Set DirectSound hardware acceleration to Basic 
dsoundhw=Emulation       Set DirectSound hardware acceleration to Emulation 
dsoundhw=Full            Set DirectSound hardware acceleration to Full (default) 
dsoundhw=Standard        Set DirectSound hardware acceleration to Standard

carasin ★★★★★ ()
Ответ на: комментарий от AleksandrArkhipov

Какая разница, на работу игрушек это не повлияет.

anonymous ()

Пускал звук в обход поцаудио. Для федорки:

rpm -e alsa-plugins-pulseaudio
В winecfg выбирал alsa в настройках вывода звука.

fjoe ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.