LINUX.ORG.RU

LAMP и несколько сайтов на 127.0.0.1


0

1

Доброй ночи.

Раньше у меня стояла убунту 10.04 и все было ок. Т.е. в etc/hosts мог прописать хоть десяток сайтов на ip 127.0.0.1, при этом добавив хост в etc/apache2/sites-enabled и они все работали.

Недавно установил 12.04, по-новой поставил LAMP, теперь не могу создать несколько сайтов на локальный айпишник один. Т.е. для каждого нового сайта нужно писать другой - 127.0.0.x. И то не всегда работает.

Возможно, ранее я что-то настраивал в конфигах каких-то, что работало с одним ип. Не подскажете, как исправить это?

★★

Хм. У меня 12.04 а раньше и другие версии. Всегда работало, и счас проверил, работает.

По идее никаких настроек не надо. В файле /etc/apache2/ports.conf должны быть строки:

NameVirtualHost *:80
Listen 80

Слушать все что не приколочено.

Munhgauzen ()

Но не забываем писать имена в файле /etc/hosts за ипом через пробел. Нельзя писать несколько строк с одним ипом.

Munhgauzen ()
Ответ на: комментарий от Munhgauzen

Есть эти строки. Ты каким образом сайты добавляешь?

Я создаю конфиг хоста в /etc/apache2/sites-available, потом в /etc/hosts прописываю этот хост: 127.0.0.1 site.loc, потом a2ensite и релоад апача.

Но это автоматизировано скриптом у меня. Гуглил - везде попадалось, что люди все хосты прописывают в httpd.conf. Но у меня явно было не так, т.к. скрипт добавления сайтов остался с прошлой версии убунты.

emissar ★★ ()
Ответ на: комментарий от emissar

создаю конфиг хоста в /etc/apache2/sites-available -> потом a2ensite и релоад апача. -> потом в /etc/hosts прописываю этот хост: 127.0.0.1

аналогично

Сейчас 12 сайтов настроено.

Munhgauzen ()
Ответ на: комментарий от emissar

Гуглил - везде попадалось, что люди все хосты прописывают в httpd.conf.

Эта кривизна в виндах и другой маргинальщине. В Debian/Ubuntu максимально используются возможности инклуда конфигов. Для шелковистости волос администратора.

Munhgauzen ()
Ответ на: комментарий от emissar

И вот конфиг одного из хостов (/etc/apache2/sites-available/modulezf):

<VirtualHost *:80>
        ServerName modulezf.tld
        ServerAlias www.modulezf.tld
        DocumentRoot /var/www/modulezf/public

        SetEnv APPLICATION_ENV development

        <Directory />
                Options FollowSymLinks
                AllowOverride All
        </Directory>

        <Directory "/var/www/modulezf/public">
                Options Indexes MultiViews FollowSymLinks
                AllowOverride All
                Order allow,deny
                Allow from all
        </Directory>
</VirtualHost>
Munhgauzen ()
Ответ на: комментарий от Munhgauzen

А еще в виртуальной коробке стоит восьмерочка. Там сеть настроена бриджем. Она ип получает от точки доступа также как и хостовая система.

129.168.0.2 хостовая машина

129.168.0.3 виртуалочка

в c:\windows\system32\drivers\etc\hosts прописываю:

192.168.0.2 modulezf.tld

И ослом захожу по имени. Удобно.

Munhgauzen ()
Ответ на: комментарий от Munhgauzen

Конфиг аналогичный практически у меня. Больше 30 штук их я скопировал с прошлой версии убунты, где они прекрасно работали. Нашел некую закономерность:

Если в самом начале каждого конфига сайта прописать NameVirtualHost адрес_сайта, то сайты начинают работать, но при релоаде апача вываливается куча предупреждений, вида

[Fri Aug 10 03:01:09 2012] [warn] NameVirtualHost tes.loc:0 has no VirtualHosts

emissar ★★ ()
Ответ на: комментарий от emissar

Бред какой-то :D Сейчас удалил строку NameVirtualHost адрес_сайта из конфигов, перезагрузил апач - сайты работают. Кажется, я схожу с ума.

emissar ★★ ()
Ответ на: комментарий от emissar

(тихо) может ты их не добавлял? a la убитые сим-линки в sites-enabled, ведущие в никуда. в общем, смотри что изменислось с «не работает» на «работает».

beastie ★★★★★ ()
Ответ на: комментарий от beastie

Добавлял, все ок. Я же говорю - когда каждому сайту ставил другой ип (127.0.0.x) они открывались. Теперь же я ничего не делал (просто попробовал добавить в конфиги сайтов строку NameVirtualHost, а потом ее так же удалил) и все встало на свои места...

emissar ★★ ()
Ответ на: комментарий от emissar

Если

apachectl -S 

в конце выдает

Syntax OK

И при этом все опять сломается... Переставь системник, это место проклятое :)

Munhgauzen ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.