LINUX.ORG.RU

Проблема в пакете pam_usb. Не сохраняется конфигурационный файл.

 ,


0

1

Установлено CentOS 6.2 x86-64 После установки пакета pam_usb ( служит для авторизации системы с помощью флешки ) выдает следующее

*[root@localhost ~]# sudo pamusb-conf --add-device my-usb-stic
Please select the device you wish to add.
* Using "Kingston DataTraveler G3 (001CC05FE935BC40992800C1)" (only option)

Which volume would you like to use for storing data ?
* Using "/dev/sdb1 (UUID: B89F-BCA3)" (only option)

Name		: my-usb-stic
Vendor		: Kingston
Model		: DataTraveler G3
Serial		: 001CC05FE935BC40992800C1
UUID		: B89F-BCA3

Save to /etc/pamusb.conf ?
[Y/n] y
Unable to read /etc/pamusb.conf: not well-formed (invalid token): line 43, column 52

Хотя должен :

$*[root@localhost ~]# sudo pamusb-conf --add-device my-usb-stic
Please select the device you wish to add.
* Using "Kingston DataTraveler G3 (001CC05FE935BC40992800C1)" (only option)

Which volume would you like to use for storing data ?
* Using "/dev/sdb1 (UUID: B89F-BCA3)" (only option)

Name		: my-usb-stic
Vendor		: Kingston
Model		: DataTraveler G3
Serial		: 001CC05FE935BC40992800C1
UUID		: B89F-BCA3

Save to /etc/pamusb.conf ?
[Y/n] y
done

и затем по идее я должен добавить пользователей но как я понимаю это ошибка в pamusb.conf. программа не может сохранить почему то конфигурацию в этот файл , вроде как понимаю 43 строка , 52 символ . Я так и не понял что именно не так , ниже мой файл конфигурации :


<!--
pamusb.conf: Configuration file for pam_usb.

See http://www.pamusb.org/doc/configuring
-->

<configuration>
	<!-- Default options -->
	<defaults>
		<!-- Example:
			<option name="debug">true</option>
		-->
	</defaults>

	<!-- Device settings -->
	<devices>
		<!-- Example:
		Note: You should use pamusb-conf to add devices automatically.
		<device id="MyDevice">
			<vendor>SanDisk Corp.</vendor>
			<model>Cruzer Titanium</model>
			<serial>SNDKXXXXXXXXXXXXXXXX</serial>
			<volume_uuid>6F6B-42FC</volume_uuid>
			<option name="probe_timeout">10</option>
		</device>
		-->
	</devices>


	<!-- User settings -->
	<users>
		<!-- Note: Use pamusb-conf to add a user, then you can tweak
		 	manually the configuration here if needed.
		-->

		<!-- Example:
			Authenticate user scox using "MyDevice", and configure pamusb-agent
			to automatically start/stop gnome-screensaver on key insertion and
			removal:
			<user id="scox">
				<device>MyDevice</device>
				<option name="quiet">true</option>
				<agent event="lock">gnome-screensaver-command --lock</agent>
				<agent event="unlock">gnome-screensaver-command --deactivate</agent>
			</user>

			Configure user root to authenticate using MyDevice, but update one
			time pads at every login (default is 1 hour):
			<user id="root">
				<device>MyDevice</device>
				<option name="pad_expiration">0</option>
			</user>
		-->
	</users>

	<!-- Services settings (e.g. gdm, su, sudo...) -->
	<services>
		<!-- Example: Speed up hotplugging by disabling one time pads -->
		<!--
		<service id="pamusb-agent">
			<option name="one_time_pad">false</option>
		</service>
		-->

		<!-- Disable output for 'su' (needed for gksu) -->
		<!--
		<service id="su">
			<option name="quiet">true</option>
		</service>
		-->
	</services>
</configuration>

Спасибо заранее.

Unable to read /etc/pamusb.conf: not well-formed (invalid token): line 43, column 52

Да, ошибка на строке 43, 52-й символ.

ниже мой файл конфигурации :

Используйте теги [code]..[/code], или http://paste.org.ru/. Или, хотя бы, кнопку «Предпросмотр».

AITap ★★★★★ ()
Ответ на: комментарий от bigstan

блин теперь другая проблема ... флешку не воспринимает, вот лог

[root@localhost ~]# pamusb-conf --add-device usbkey
Please select the device you wish to add.
* Using "Kingston DataTraveler G3 (001CC05FE935BC40992800C1)" (only option)

Which volume would you like to use for storing data ?
* Using "/dev/sdb1 (UUID: B89F-BCA3)" (only option)

Name		: usbkey
Vendor		: Kingston
Model		: DataTraveler G3
Serial		: 001CC05FE935BC40992800C1
UUID		: B89F-BCA3

Save to /etc/pamusb.conf ?
[Y/n] y
Done.
[root@localhost ~]# # pamusb-conf --add-user root
[root@localhost ~]# pamusb-conf --add-user root
Which device would you like to use for authentication ?
0) my-usb-stic
1) usbkey

[0-1]: 1

User		: root
Device		: usbkey

Save to /etc/pamusb.conf ?
[Y/n] y
Done.
[root@localhost ~]# pamusb-check root
* No device configured for user "root".
[root@localhost ~]# 

* No device configured for user «root». [root@localhost ~]# ------------- это как ?

bigstan ()
Ответ на: комментарий от AITap

вот

<?xml version="1.0" ?><!--
pamusb.conf: Configuration file for pam_usb.

See http://www.pamusb.org/doc/configuring
--><configuration>
	<!-- Default options -->
	<defaults>
		<!-- Example:
			<option name="debug">true</option>
		-->
	</defaults>

	<!-- Device settings -->
	<devices>
		<!-- Example:
		Note: You should use pamusb-conf to add devices automatically.
		<device id="MyDevice">
			<vendor>SanDisk Corp.</vendor>
			<model>Cruzer Titanium</model>
			<serial>SNDKXXXXXXXXXXXXXXXX</serial>
			<volume_uuid>6F6B-42FC</volume_uuid>
			<option name="probe_timeout">10</option>
		</device>
		-->
	<device id="usbkey">
	<vendor>
		Kingston
	</vendor>
	<model>
		DataTraveler G3
	</model>
	<serial>
		001CC05FE935BC40992800C1
	</serial>
	<volume_uuid>
		B89F-BCA3
	</volume_uuid>
</device></devices>


	<!-- User settings -->
	<users>
		<!-- Note: Use pamusb-conf to add a user, then you can tweak
		 	manually the configuration here if needed.
		-->


	<user id="root">
	<device>
		usbkey
	</device>
</user></users>

	<!-- Services settings (e.g. gdm, su, sudo...) -->
	<services>
		<!-- Example: Speed up hotplugging by disabling one time pads -->
		<!--
		<service id="pamusb-agent">
			<option name="one_time_pad">false</option>
		</service>
		-->

		<!-- Disable output for 'su' (needed for gksu) -->
		<!--
		<service id="su">
			<option name="quiet">true</option>
		</service>
		-->
	</services>
</configuration>

bigstan ()
Ответ на: вот от bigstan

И даже после перезагрузки ничего не работает?

pam-usb.so уже указан в конфиге PAM?

AITap ★★★★★ ()
Ответ на: комментарий от AITap

вот мой system-auth

#%PAM-1.0
# This file is auto-generated.
# User changes will be destroyed the next time authconfig is run.

auth        required      pam_env.so

auth        sufficient    pam_fprintd.so
auth        sufficient    pam_usb.so
auth        sufficient    pam_unix.so try_first_pass likeauth nullok
auth        sufficient    pam_unix.so nullok try_first_pass
auth        requisite     pam_succeed_if.so uid >= 500 quiet
auth        required      pam_deny.so
account     required      pam_access.so
account     required      pam_unix.so
account     sufficient    pam_localuser.so
account     sufficient    pam_succeed_if.so uid < 500 quiet
account     required      pam_permit.so

password    requisite     pam_cracklib.so try_first_pass retry=3 type=
password    sufficient    pam_unix.so sha512 shadow nullok try_first_pass use_authtok
password    required      pam_deny.so

session     optional      pam_keyinit.so revoke
session     required      pam_limits.so
session     [success=1 default=ignore] pam_succeed_if.so service in crond quiet use_uid
session     required      pam_unix.so

bigstan ()
Ответ на: вот мой system-auth от bigstan

Тогда это похоже на какой-то баг. Если, конечно, в документации pam-usb не сказано, например, что перед pamusb-check флешку нужно вынуть.

AITap ★★★★★ ()
Ответ на: комментарий от AITap

если вынуть то показывает это

[root@localhost ~]# pamusb-check
Usage: pamusb-check [--help] [--debug] [--config=path] [--service=name] [--dump] [--quiet] [--debug] <username>
[root@localhost ~]# 
bigstan ()
Ответ на: комментарий от bigstan

Usage: pamusb-check [--help] [--debug] [--config=path] [--service=name] [--dump] [--quiet] [--debug] <username>

Видимо, снова pamusb-check root. Попробуйте изучить man pamusb-check и попробовать разные параметры вроде --debug.

AITap ★★★★★ ()
Ответ на: комментарий от AITap

вот только что дал положительный результат , а команда su не работает (( и выдает теперь под рут когда хочешь зайти теперь сбой при проверке подлинности...

bigstan ()
Ответ на: комментарий от AITap
root@localhost ~]# pamusb-check root
* Authentication request for user "root" (pamusb-check)
* Device "usbkey" is connected (good).
* Performing one time pad verification...
* Regenerating new pads...
* Access granted.
[root@localhost ~]# su
[root@localhost ~]# 
[root@localhost ~]# 
bigstan ()
Ответ на: комментарий от bigstan

для su отдельная конфигурация в /etc/pam.d/su. посмотри

aol ★★★★★ ()
Ответ на: комментарий от bigstan

auth.log что то я в системе не нашел...

Поищите в /var/log/

[root@localhost ~]# su
[root@localhost ~]#

Почитайте какую-нибудь книгу по GNU/Linux. su из-под root не требует аутентификации. Вообще.

AITap ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.