LINUX.ORG.RU

xmodmap перестал работать после обновления

 ,


0

1

У меня всегда был заремаплен CapsLock на Control. Делалось это в файле ~/.Xmodmap так:

remove Lock = Caps_Lock
remove Control = Control_L
keysym Caps_Lock = Control_L
add Lock = Caps_Lock
add Control = Control_L
и работало уже несколько лет без каких-либо проблем. Сегодня обнаружил, что капс снова работает как капс и попытка выполнить xmodmap ~/.Xmodmap выдает следующее:
gaga@gaga:~$ xmodmap ~/.Xmodmap 
xmodmap:  /home/gaga/.Xmodmap:1:  bad keysym in remove modifier list 'Caps_Lock', no corresponding keycodes
xmodmap:  /home/gaga/.Xmodmap:3:  bad keysym target keysym 'Caps_Lock', no corresponding keycodes
xmodmap:  2 errors encountered, aborting.
Пример из мана, скопипащенный один в один, тоже не работает. С чего это взялось и как с этим бороться?


А что xmodmap без аругментов выводит? (до применения пользовательских настроек)

anonymous ()
Ответ на: комментарий от anonymous
gaga@gaga:~$ xmodmap 
xmodmap:  up to 4 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Control_L (0x42)
control     Control_L (0x25),  Control_R (0x69)
mod1        Alt_L (0x40),  Alt_R (0x6c),  Meta_L (0xcd)
mod2        Num_Lock (0x4d)
mod3      
mod4        Super_L (0x85),  Super_R (0x86),  Super_L (0xce),  Hyper_L (0xcf)
mod5        ISO_Level3_Shift (0x5c),  Mode_switch (0xcb)
gaga ()
Ответ на: комментарий от gaga

Здесь уже нет капса, возможно поменялись настройки иксов, проверьте xkboption.

И всегда можно настроить через keycode <num> вместо keysym (посмотреть с помощью xev для Caps_Lock).

anonymous ()
Ответ на: комментарий от anonymous

Спасибо. Я не понял, что это было, но оно теперь заработало. При этом xev отображает те же правильные keysym для капса (Control_L), что и когда не работал. Странно это все.

gaga ()

JFYI, это делается при помощи XKB без всяких фокусов.

GotF ★★★★★ ()
Ответ на: комментарий от GotF

Для общего развития. как именно? // чтобы левый Control срабатывал как Cap

anonymous ()
Ответ на: комментарий от anonymous

setxkbmap -option «ctrl:swapcaps»

Но как не затронуть правый Ctrl я не знаю.

GotF ★★★★★ ()
Ответ на: комментарий от GotF

Просто вы сказали, что прямее (точнее «без фокусов»)

xmodmap - низкоуровневый «патч» на keymap, в xkboptions - предопределенные, не вижу фокусов).

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.