LINUX.ORG.RU

[Gentoo] USB


0

1

Есть Gentoo, ядро 3.2.9, если подключить клаву и мышь в парный usb разъем, то клава или мышка не работают. Думается, что чего-то в ядре не хватает. Буду рад, если подскажите, чего не хватает.

Спасибо.

★★★

Ответ на: комментарий от post-factum

Не знал как правильно сказать.

Проще говоря, два разъема usb, которые находятся рядом.

Нет, с питанием все в порядке, именно если воткнуть одновременно клаву и мышь в них, работает только, что-то одно.

На арче все гуд, но там ядро из дистрибутива, поэтому думаю, что я чего то не включил в ядро.

SAA ★★★ ()
Ответ на: комментарий от tazhate

Возможно.

Вот конфиг:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="mmx sse sse2 sse4.1 sse4.2 \
        multilib nls X kde opengl qt4 icu \
        lzma vdpau bash-completion \
        -pulseaudio -handbook -semantic-desktop \
        -gnome -hal -gtk -bluetooth -gtk3"

ACCEPT_KEYWORDS="~amd64"
ACCEPT_LICENSE="*"
VIDEO_CARDS="nvidia"
LINGUAS="en ru"
MAKEOPTS="-j5"

PORTDIR_OVERLAY="/usr/local/portage"
source /var/lib/layman/make.conf                                                                                                                  
                                                                                                                                                  
GENTOO_MIRRORS="http://mirror.timeweb.ru/gentoo"
SYNC="rsync://rsync4.ru.gentoo.org/gentoo-portage"
SAA ★★★ ()
Ответ на: комментарий от tazhate

И верно, раньше была, видно куда-то я ее дропнул. Сейчас проверим.

SAA ★★★ ()
Ответ на: комментарий от tazhate

Оно вместе не работает емнип. Какая-то опция типа AllowEmptyInput или AutoAddDevices позволяет работать либо evdev, либо старым дровам, тоже емнип.

tiandrey ★★★★★ ()
Ответ на: комментарий от tiandrey

Оно вместе не работает емнип.

Работает. Пишу с такой системы как раз.
К слову говоря, опять же, емнип, это включает поддержку что собирать/что не собирать, а не отвечает напрямую за изменения каких-либо конфигов. Просто иксы подключают евдев, если он в системе есть, а остальное не берут. Опять же, емнип.

tazhate ★★★★★ ()

Скорее, это аппаратное. У меня в буке была похожая ерунда. Поначалу работал лишь один из двух разъемов в группе, теперь один из них сдох окончательно. Пока не разбирался, что не так, но поначалу тоже грешил на систему

MahMahoritos ★★★ ()
Ответ на: комментарий от tazhate

INPUT_DEVICES-то да, включает зависимость пакета x11-drivers от соответствующих драйверов, а те опции - в xorg.conf, и иксы не грузят драйвера, если они включены (или выключены, whatever).

tiandrey ★★★★★ ()
Ответ на: комментарий от MahMahoritos

Не, как уже писал в другом дистре все гуд. Тут явно руки.

SAA ★★★ ()
Ответ на: комментарий от tazhate

Вот, ни одного упоминания драйвера keyboard или mouse. Благословляю тебя почистить систему от 2 (двух!) ненужных пакетов.

tiandrey ★★★★★ ()
Ответ на: комментарий от SAA

Ты несколько раз в tty что-ли переключался?

Если вытащить мышь, то клава нормально работает? И что именно не работает когда оба подключены?

Ivan_qrt ★★★★★ ()
Ответ на: комментарий от SAA

А х его з, у тебя вроде как всё нормально определяется, но потом теряется всё, кроме клавы, попробуй откатиться на стабильный xorg-server и xf86-input-evdev < 2.7.

Ivan_qrt ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.