LINUX.ORG.RU

CentOS 5.x выбор репозиториев Remi/Atomic/CentosALT


0

1

Привет всем.

Задача: Поднять актуальный web server 5 и 6 версии CentOS Помогите определится с доп репами. Цели:

1. CentOS 5.x — php 5.2.x, httpd 2.2.x, MySQL 5.1.x

2. CentOS 6.x — php 5.3.x, httpd 2.2.x, MySQL 5.5.x

PHP

Для 5 версии: нужен php версии 5.2.x на мой взгляд больше подходит CentosALT там быстрее накладываются патчи Для 6 версии думаю тоже, хотя Remi и Atomic тоже предоставляют актуальные 5.3.х Кому больше вы доверяете?

HTTPD

Тут выбор только один, CentosALT в остальных попросту нет Apache

MySQL

Для 5 версии нужен 5.1.x тут подходит только Atomic Для 6 само собой Remi или все же Atomic? Нужна версия 5.5.х

Что вы думаете по этому поводу…


А насчёт локальных реп ? Правда это геморно, каждый день сидеть и проверять новые версии пакетов.

dada ★★★★★ ()

Дополнительные репы не кошерны. Зачем мешать редхатовские пакеты с пользовательскими?

OvO ()

Лампами я не занимаюсь, поэтому что где какой свежести из этого что ты перечислил не знаю. Но для центоса и прочих сверхстабильных считается нормальной практикой подключить сразу все необходимые 3rdparty репозитории, но держать их отключенными (enabled=0). При необходимости надо запускать yum, явно тыкая его в эти репозитории (типа yum install --enablerepo=... или yum search --enablerepo=...).

Разумеется, нужно помнить, что 3rdparty по определению друг с другом не совместимы, и в некоторых пакетах могут очень нехорошо пересекаться.

Естественно, подключаемые 3rdparty репы должны быть живыми, софт в них должен обновлятся (естественно, не ломая ABI, коль скоро речь идёт об энтерпрайзе), у них должен быть список рассылки или какой-то другой канал, по которому можно связаться с людьми, его поддерживающими.

В конце концов, компили/патчи сам в уютный локальный реп, если хватает ресурсов.

Более вроде, вариантов для центоса не придумали ещё.

d_a ★★★★★ ()

Для 5 версии: нужен php версии 5.2.x

есть php53 в базовой поставке

HTTPD
Тут выбор только один, CentosALT в остальных попросту нет Apache

в базовой поставке нет apache??

MySQL
Для 5 версии нужен 5.1..
Что вы думаете по этому поводу…

да много чего думаю, можно и с родного mysql сайта ставить

anonymous2 ★★★★★ ()
Ответ на: комментарий от anonymous2

есть php53 в базовой поставке

речь идет о 5 ветке, там 5.1.6 в базовой поставке

в базовой поставке нет apache??

нужен индеец актуальной версии

да много чего думаю, можно и с родного mysql сайта ставить

можно, я мой вопрос о трех репозиториях

Sky4eg ()
Ответ на: комментарий от Sky4eg

есть php53 в базовой поставке

речь идет о 5 ветке, там 5.1.6 в базовой поставке

Подозреваю что анонимус имел в виду epel

kernel ★★☆ ()
Ответ на: комментарий от Sky4eg

2.2.22 не?

включи уж мозг, последняя цифирь 22 это багфиксы..

anonymous2 ★★★★★ ()
Ответ на: комментарий от Sky4eg

Есть возможность сделать black list, который есть не что иное как инвертированный while list. (вписать exclude=«список пакетов» в нужный файл 3rdparty.repo)

d_a ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.