LINUX.ORG.RU

Продолжение темы про автоответчик).


0

0

Перепроверил я несколько раз конфиги
и пришёл к выводу, что всё с ними нормально.
Посмтрел логи vgetty

/var/log/vgetty.ttyS0
--
12/19 14:02:51 yS0 vgetty: experimental test release 0.9.32 / 24Dec01
12/19 14:02:51 yS0 mgetty: experimental test release 1.1.30-Dec16
12/19 14:02:51 yS0 reading program vgetty configuration from config file /etc/mgetty+sendfax/voice.conf
12/19 14:02:51 yS0 reading port ttyS0 configuration from config file /etc/mgetty+sendfax/voice.conf
12/19 14:02:51 yS0 check for lockfiles
12/19 14:02:51 yS0 locking the line
12/19 14:02:51 yS0 can't get group 'modem': Success
12/19 14:02:51 yS0 lowering DTR to reset Modem
12/19 14:02:52 yS0 send: \dATQ0V1H0[0d]
12/19 14:02:53 yS0 waiting for ``OK'' ** found **
12/19 14:02:53 yS0 send: ATS0=0Q0&D3&C1[0d]
12/19 14:02:53 yS0 waiting for ``OK'' ** found **
12/19 14:02:53 yS0 mdm_send: 'ATI'
12/19 14:02:53 yS0 Generic Rockwell modem (56000)
12/19 14:02:53 yS0 mdm_send: 'ATI3'
12/19 14:02:53 yS0 mdm_send: 'ATI4'
12/19 14:02:53 yS0 additional info: 'FM-56SA-Smart V.92 & V.90 Modem 2002/03/24'
12/19 14:02:53 yS0 modem quirks: 0004
12/19 14:02:53 yS0 mdm_send: 'AT+FCLASS=2' -> OK
12/19 14:02:53 yS0 mdm_send: 'AT+FCLASS=0' -> OK
12/19 14:02:53 yS0 mdm_send: 'AT+FAA=1;+FCR=1' -> OK
12/19 14:02:53 yS0 mdm_send: 'AT+FBOR=0' -> OK
12/19 14:02:53 yS0 mdm_send: 'AT+FLID="49 115 xxxxxxxx"' -> OK
12/19 14:02:53 yS0 mdm_send: 'AT+FDCC=1,5,0,2,0,0,0,0' -> OK
12/19 14:02:53 yS0 detecting voice modem type
12/19 14:02:55 yS0 Rockwell detected
12/19 14:03:06 yS0 vgetty: timeout while reading character from voice modem
12/19 14:03:06 yS0 initializing ROCKWELL voice modem
12/19 14:03:06 yS0 vgetty: Modem returned ERROR
12/19 14:03:06 yS0 can't set silence period
12/19 14:03:06 yS0 vgetty: Modem returned ERROR
12/19 14:03:06 yS0 can't set transmit gain
12/19 14:03:06 yS0 vgetty: Modem returned ERROR
12/19 14:03:06 yS0 can't set record gain
12/19 14:03:06 yS0 vgetty: Modem returned ERROR
12/19 14:03:07 yS0 can't disable silence deletion
12/19 14:03:07 yS0 vgetty: Modem returned ERROR
12/19 14:03:07 yS0 can't set DLE responses
12/19 14:03:07 yS0 vgetty: Modem returned ERROR
12/19 14:03:07 yS0 can't set silence threshold
12/19 14:03:07 yS0 vgetty: Modem returned ERROR
12/19 14:03:08 yS0 waiting...
--

думаю, что не работает именно из-за этого =(.
что за ошибки в конце?..
Дистрибутив и версия ядра роли не играют, наверное.
Помогите, плиз!!!..

anonymous

Re: Продолжение темы про автоответчик).

AFAIK на Acorp`ax оно вообще не работает. У меня EMSF-2, и тоже не завелся автоответчик. Лучше взять нормальный модем типа Zyxel 56k OMNI Pro

anonymous ()
Ответ на: Re: Продолжение темы про автоответчик). от anonymous

Re: Re: Продолжение темы про автоответчик).

в таком случае может пожешь мне деньгами на новый модем? =) Б*я, а щас ещё и новый нод, подарки, расходы).. А нет ли случаем какого-либо патча?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.