LINUX.ORG.RU

винт не монтируется как надо


0

0

Поставил генту, вроде все как на www.gentoo.ru, по поводу руссификации, сделал, в некоторых програмах появился русский, даже этот текст нормально пишется. Но вот винт не монтируется как мне надо. делаю так mount -t vfat /dev/hda1 /mnt/hd1 -o iocharset=koi8-r, а он не монтирует, а говорит: mount: wrong fs type, bad option, bad superblock on /dev/hda1, or too many mounted file systems если без iocharset=kio8-r делать, то вместо русских букв вопросы... ядро 2.4.26, кирилические шрифты вроде есть.. на #locale отвечает LANG=ru_RU.KOI8-R LC_CTYPE="ru_RU.KOI8-R" LC_NUMERIC=POSIX LC_TIME="ru_RU.KOI8-R" LC_COLLATE="ru_RU.KOI8-R" LC_MONETARY="ru_RU.KOI8-R" LC_MESSAGES="ru_RU.KOI8-R" LC_PAPER="ru_RU.KOI8-R" LC_NAME="ru_RU.KOI8-R" LC_ADDRESS="ru_RU.KOI8-R" LC_TELEPHONE="ru_RU.KOI8-R" LC_MEASUREMENT="ru_RU.KOI8-R" LC_IDENTIFICATION="ru_RU.KOI8-R" LC_ALL=

что делать?.. зарание спасибо.

anonymous

Re: винт не монтируется как надо

Может у тебя не собрана поддержка соответствующих кодировок в ядре?

redchrom ()

Re: винт не монтируется как надо

Еххх... Неужто придется еще и голые строчки для монтирования писать..

mount /dev/откуда /mnt/куда -t vfat -o rw,iocharset=koi8-r,codepage=866,umask=0,showexec,quiet

Не 860, а 866. И без cp, заметь.

Теперь по поводу твоей ошибки. То, что ты параметры разные указываешь, тебе не поможет.

mount: wrong fs type, bad option, bad superblock on /dev/hda1, or too many mounted file systems если без iocharset=kio8-r

Раз без iocharset у тебя все работает как надо, значит где-то ты не так указываешь параметр. Возможно, написал не iocharset, а iochasret ;)

jackill ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.