LINUX.ORG.RU

gentoo & emerge


0

0

Пишу emerge kde, а он пытается скачать xfree, ну поставил я его отдельно: emerge xfree, а скде такая же ерунда. Как указать, чтоб emerge не спрашивал определённого пакета?, --nodeps не подходит, наверное, к примеру что kde, не искал этот самый xfree, а все остальные зависимости удовлеторял. зарание спасибо

anonymous

Re: gentoo & emerge

emerge скорее всего пытается обновить xfree, т.к. этого требует зависимости
kde.

открою тебе небольшой секрет: kde без xfree (или xorg) не работает.

можно поставить более старый вариант kde или указать portage что такой пакет
уже поставлен(xfree), можно еще указать что не надо обновлять kde.

в общем много чего можно и все это можно узнать из

man emerge
man kde

http://gentoo.org раздел документации.

fghj ★★★★★ ()

Re: gentoo & emerge

Из бинарей КДЕ ставишь или из исходников? Предположу, что из бинарей. Тогда:

# emerge -k kde

Если не поможет, то

# echo --inject x11-base/xfree-VERSION

Если не сработает, а об этом будет сказано красными буквами, то

# echo ">x11-base/xfree-VERSION" >> /etc/portage/package.mask

# emerge -k kde

xfree-VERSION - это та версия, которую ты отдельно установил.

theSoul ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.