LINUX.ORG.RU

gentoo, kernel 3.1.6, fglrx проблемы


0

1

обновился c 3.0.6 до 3.1.6
Все грузится, но при загрузке иксов, загружается черный экран, а потом ничего
дальше не происходит. Я копался в меню
-> Device Drivers
-> Graphics support
Direct Rendering Manager и Support for frame buffer devices

видеокарта у меня Radeon 6670(PCI-X), драйвера перекомпилировал,
подгрузил, а иксы все равно не хотят грузится.

пытался вообще ничего не трогать в этом меню, все равно не грузятся иксы.

на сайте ati, для компиляции даются такие конфиги
Device Drivers --->
Graphics Support --->
<M> /dev/agpgart (AGP Support)
<M> Your_AGP_Chipset_Here
[ ] Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)

Graphics support --->
[ ] Support for framebuffer devices
пруф

Ответ на: комментарий от daemonpnz

я делал в таком порядке:
emerge -C ati-drivers
emerge ati-drivers
выхожу из иксов, удаляю модуль rmmod fglrx
подгружаю модуль modprobe fglrx
стартую иксы
эта связка не работала

а надо было вручную удалить модуль и только потом делать все в том же самом порядке.
rm /lib/modules/$(uname -r)/video/fglrx.ko

теперь все работает.

yanmhlv ()
Ответ на: комментарий от yanmhlv

Не надо ничего руками удалять. Обновляешь ядро, собираешь его, кладёшь его в бут, обновляешь модули, обновляешь конфигурацию груба, пересобираешь fglrx, после этого ребут и всё прекрасно работает. Нафига удалять и ставить ati-drivers я вообще не понимаю.

daemonpnz ★★★★★ ()
Ответ на: комментарий от bsdfun

пользуясь случаем, задам еще вопрос)
после обновления ядра, у меня стал лагать full hd видео
в частности, при воспроизведение 1080p роликов на youtube, при полном экране, видео идут чуть ли не по кадрам. С чем связано - хз. На 3.0.6 все нормально

yanmhlv ()
Ответ на: комментарий от daemonpnz

yan@localhost /opt/bin $ fglrxinfo
display: :0 screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6670
OpenGL version string: 4.2.11318 Compatibility Profile Context

yan@localhost /opt/bin $ fgl_glxgears
Using GLX_SGIX_pbuffer
13879 frames in 5.0 seconds = 2775.800 FPS
14812 frames in 5.0 seconds = 2962.400 FPS
14891 frames in 5.0 seconds = 2978.200 FPS
12801 frames in 5.0 seconds = 2560.200 FPS
1267 frames in 5.0 seconds = 253.400 FPS
1253 frames in 5.0 seconds = 250.600 FPS

в двух последних строчках я развернул окно на полный экран, поэтому идет замедление.
монитор у меня 24" 1920*1080

yanmhlv ()
Ответ на: комментарий от daemonpnz

[ebuild R ~] www-client/google-chrome-16.0.912.63_p113337 USE=«plugins» LINGUAS=«ru» 0 kB
[ebuild R ] www-plugins/adobe-flash-11.1.102.55 USE=«64bit (multilib) -32bit -kde -vdpau» 0 kB
[ebuild R ] kde-base/kde-meta-4.7.3 USE=«nls -accessibility (-aqua) -sdk -semantic-desktop» 0 kB
[ebuild R ~] x11-drivers/ati-drivers-11.12 USE=«modules (multilib) opencl qt4 -debug» 0 kB

yanmhlv ()
Ответ на: комментарий от daemonpnz

я как то добивался, чтобы не было лагов при воспроизведении, но как на зло, не помню что делал. Т.е. делал все как обычно, но почему то тогда видео работало замечательно. Кстати, композит были включены всегда у меня. Да и из эффектов у меня только полу прозрачность включена

yanmhlv ()
Ответ на: комментарий от daemonpnz

я воспроизводил ролик, который сохранился в кэше браузера, тоже лагает

yanmhlv ()
Ответ на: комментарий от daemonpnz

воспроизведение флеш ролика качеством 360 в браузере, в полном экране тоже тормозит

нашел в интернете такое решение:
/etc/adobe/mms.cfg.
OverrideGPUValidation=true

рестартнул браузер, не помогает.

yanmhlv ()
Ответ на: комментарий от daemonpnz

запустил флеш в виртуалке с разрешением 1920х1080. дистр calculate в chromium'e full hd видео проигрывается без лагов

yanmhlv ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.