LINUX.ORG.RU

Обновление rpm


0

0

Проблема такая. Дистрибутив старый ( rh release 5.9 ). Поставил на него новый rpm 4.0.2. (старая версия была кажется 2.9) Пришлось из src собирать. Попутно возник еще один вопрос: зачем везде rpm4 выкладывают в rpm4 пакете?? (его же нельзя ничем, кроме 4ой версии, поставить).
Но главная проблема в том, что rpm -qa не показывает установленных пакетов.
Как его заставить "вспомнить" , что уже установленно? (в /var/lib/rpm осталось много всякой инфы). Прочитал доки , которые были вместе с src, но там что-то ничего не обнаружил такого.
Подскажите, пожалуйста, как это сделать ,если это возможно? Или такие переходы предполагают покупку нового дистрибутива (который уже с rpm4)?

anonymous

Re: Обновление rpm

У RPM-4.0.x другой формат базы. Поэтому нужно преконвертировать. Но лучне поставить RPM>=3.0.5, он понимает формат 4-го.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.