LINUX.ORG.RU

ZTE MF180 от Velcom на Ubuntu 10.04


0

1

На Ubuntu 10.04 при подключении usb модема ничего не происходит,

даже в «Компьютере» не отображается.

Качал «usb-modeswitch_1.1.0-2_i386.deb» и «usb-modeswitch-data_20100127-1_all.deb» с сайта ubuntu.com.

Устанавливал так:

cd /home/profile/

sudo sh usb-modeswitch_1.1.0-2_i386.deb

sudo sh usb-modeswitch-data_20100127-1_all.deb

Вылазит отшибка в двух случаях:

usb-modeswitch-data_20100127-1_all.deb: 1: Syntax error: newline unexpected


> sudo sh usb-modeswitch_1.1.0-2_i386.deb
Кхм. Работа с deb-пакетами выполняется при помощи dpkg.
Это раз.

Работа с модемом должна производиться при помощи NetworkManager, который уже установлен в системе. Это два.

Если модем определяется, как USB-CD, просто нажмите на его значке «извлечь». Это три.

AITap ★★★★★ ()
Ответ на: комментарий от AITap

> Если модем определяется, как USB-CD, просто нажмите на его значке «извлечь».

У модема несколько режимов. Просто модем, модем + карта памяти, модем + карта памяти + CD ROM. Что-то типа того (кажется, режимов больше), так что если он определяется ещё как накопитель - это ещё не значит, что он не определился как модем.

stolz ()

Просто два раза кликни по пакетам и они установятся через Ubuntu Software Center. По крайней мере, когда я сидел на 10.04 я именно это делал и всё работало.

Да, и после установки пакетов выткни-воткни модем, и в секции Mobile Broadband создай новое соединение. Там всё должно автоматом подцепиться (если не подцепится - проверь точку доступа, т.е. погугли какая она должна быть, может не ту выставить, хотя у меня всё работало).

stolz ()
Ответ на: комментарий от stolz

Я кликал два раза - вылезла ошибка: В Вашей системе нарушены зависимости. Выполнение приложения не может быть продолжено, пока это не будет исправлено. Для исправления наберите в окне терминала 'gksudo synaptic' или 'sudo apt-get install -f'

n199a ()
Ответ на: комментарий от AITap

> Работа с deb-пакетами выполняется при помощи dpkg.

Серьезно? А GDebi для Ъ-красноглаза - это грех?

Работа с модемом должна производиться при помощи NetworkManager, который уже установлен в системе.

Если модем не определился системой как модем, NetworkManager ВНЕЗАПНО не находит устройства для создания нового Mobile Broadband Connection.

Если модем определяется, как USB-CD, просто нажмите на его значке «извлечь».

И в итоге ты все равно соснешь, потому что модем системой так и не определился.

Вывод: очередной тупоголовый иксперт-по-всему метанирует, изображая невъебенные познания. Сделай ЛОРу одолжение - убейся апстену.

anonymous ()

ТС, не хочу тебя огорчать, но вряд ли ты заведешь этот модем в 10.04 :(

Но если очень-очень хочется, то погугли следующее:

1. Mobile Partner

2. конфиги .rules, .fdi и usb_modeswitch.conf для своего модема. Они в Сети точно есть. Может, помогут.

anonymous ()

Сделайте в консоли следующие действия:

sudo tail -f /var/log/messages

после чего воткните модем в соответствующий разъём. Подождите секунд 10-20. То что появилось на экране скопируйте и поместите здесь в режиме LORCODE.

ArtSh ★★★ ()
Ответ на: комментарий от n199a

В менеджере пакетов synaptic набери «gnome-ppp» и поставь. Хотя модем должен быть до этого, ну если 11.04, то там логи отключены по дефолту в месаджес и смотреть в керн.лог надо. Но думаю он есть.

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

Оно-то Г, никто не спорит. Вот только это Г работает со всеми модемами и не просит всякие usb_modeswitch. Да и ТСу удобнее, чем конфиги ppp красноглазить.

anonymous ()
Ответ на: комментарий от anonymous

Я к тому, что если это Г работает, то и не надо оно, т.е. можно через простой ппп подключаться, а инфа в браузере есть.

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

> Не нужна она, а так есть на «диске»

Который в модеме

Ты совсем упоролся, звездатый? С каких пор опсосы заливают в модемы софт для Лялеха?

anonymous ()
Ответ на: комментарий от amorpher

Я скачал с друга ноута gnome-ppp архив. В архиве файлы. Через флешку копирую себе на ноут с Ubuntu, а как установить эту прогу?

n199a ()
Ответ на: комментарий от n199a

Сделай наперво в терминале:

sudo gnome-ppp


И там напиши имя, пароль, номер. В настройках галочки поставть только на «разместить в области уведомлений» и «игнорировать запросы». Ну и модем «определить».

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

Я предлагаю человеку нормальное решение, а ты троллишь и заставляешь его красноглазить. Он за помощью пришел, а не за конпелянием всяким.

anonymous ()
Ответ на: комментарий от anonymous

ХЗ, когда видел это Г, то там оно было (мегафон, ЕМНИП), джава же.

amorpher ★★★★★ ()
Ответ на: комментарий от n199a

С винды качай, потом (это для скайлинка хомячкам писал):

amorpher:~/Пакеты/net/ppp/gnome-ppp/gnome-ppp-lucid32$ ls
1-libwvstreams4.6-base_4.6.1-1_i386.deb 4-wvdial_1.60.3_i386.deb
2-libwvstreams4.6-extras_4.6.1-1_i386.deb 5-gnome-ppp_0.3.23-1ubuntu2_i386.deb
3-libuniconf4.6_4.6.1-1_i386.deb

(это то ^, что в папке).

1. Устанавливаешь пакеты по порядку.

2. в терминале:
sudo gnome-ppp

В программе настроишь - Имя пользователя - mobile, Пароль - internet, галочку поставь «запомнить пароль», Тел. № - #777. В настройках нажми «Определить модем».
Подключись в интернет. Отключись.

3. Скопируй себе в домашний каталог (/home/sdss) файл .wvdial.conf из /root (это домашний каталог пользователя root, перед этим включи отображение скрытых файлов).

Правой кнопкой на этом файле (.wvdial.conf) в свойствах - права замени везде root на себя (sdss).

4. Проверь, что твой пользователь имеет право выходить в интернет и пользовать модем - в меню администрирование поищи в «Users and groups» и выставь галочку на use modem (чего-то типа этого).

После того как добавил пользователя в группу необходимо выйти из сеанса и опять залогинится (чтобы твой пользователь был добавлен в те группы, которые ты добавил).

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

Когда пытался установить первый файл, то вылезла ошибка: В Вашей системе нарушены зависимости. Выполнение приложения не может быть продолжено, пока это не будет исправлено. Для исправления наберите в окне терминала 'gksudo synaptic' или 'sudo apt-get install -f'

Что делать?

n199a ()
Ответ на: комментарий от n199a

ТС, я сейчас скажу кое-что, оно тебе, возможно, не понравится, но однозначно решит все твои проблемы. Поставь 11.04 и не мучайся, там такой же GNOME + новый софт + баги пофиксили уже + модем твой заведется с полоборота. :)

anonymous ()
Ответ на: комментарий от n199a

Вот там, в окне «Менеджер пакетов Synaptic» нажми в меню «Правка», далее «Исправить пакеты с ошибками». И галочку зелёную нажми («Применить»).

amorpher ★★★★★ ()
Ответ на: комментарий от n199a

Ну да, реально анон сказал, нафиг тебе люсид? Качай нарвала, гном там же есть (выберешь в окне, там где пароль спрашивают «убунту классик», он гноме2 и есть).

amorpher ★★★★★ ()
Ответ на: комментарий от n199a

Можно это дело сделать, но много букв будет (от меня по крайней мере), так чо давай с винды качай natty narwal c http://ubuntu.com/

amorpher ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.