LINUX.ORG.RU

proftpd -> Memcache support not enabled (LMDB)


0

1

apt-get install proftpd-basic

/etc/init.d/proftpd restart
Stopping ftp server: proftpd.
Starting ftp server: proftpd - mod_tls_memcache/0.1: notice: unable to register 'memcache' SSL session cache: Memcache support not enabled

Это предупреждеи возникло сразу посля установки, я проверил НМАПОМ порты и он нашел там серв... потому сразу забыл про это...

Теперь перенес натройки сервера со совей убунты и когда я пытаюсь сконектится то выдает:
Status: Connecting to 127.0.0.1:21...
Status: Connection established, waiting for welcome message...
Response: 220 127.0.0.1 FTP server ready
Command: AUTH TLS
Response: 234 AUTH TLS successful
Status: Initializing TLS...
Error: GnuTLS error -53: Error in the push function.
Error: Could not connect to server
Status: Waiting to retry...
Status: Connecting to 127.0.0.1:21...
Status: Connection established, waiting for welcome message...
Response: 220 127.0.0.1 FTP server ready
Command: AUTH TLS
Response: 234 AUTH TLS successful
Status: Initializing TLS...
Error: GnuTLS error -53: Error in the push function.
Error: Could not connect to server

Подключаюсь FTPES (настройки точно нормальные, провереные временем под убунтами...)

LINUX MINT DEBIAN EDITION (LMDB)

Вот чтото нашел может это поможет вам помочь мне...

http://download.richlandsd.com/linux-apache-webmin/proftpd/contrib/mod_tls_me...

А именно вот (почти в самом низу):

#ifdef PR_USE_MEMCACHE
/* Register ourselves with mod_tls. */
if (tls_sess_cache_register(«memcache», &tls_mcache) < 0) {
pr_log_pri(PR_LOG_NOTICE, MOD_TLS_MEMCACHE_VERSION
": notice: error registering 'memcache' SSL session cache: %s",
strerror(errno));
return -1;
}
#else
pr_log_pri(PR_LOG_NOTICE, MOD_TLS_MEMCACHE_VERSION
": notice: unable to register 'memcache' SSL session cache: Memcache support not enabled");
#endif /* PR_USE_MEMCACHE */

return 0;
}

DenisPA ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.