LINUX.ORG.RU

[Arch][Catalyst] Артефакты


0

1

Решил поставить Catalyst. Установил из AUR и следовал инструкциям. Х запустился, но появились артефакты. Вот еще

$ lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc M92 [Mobility Radeon HD 4500 Series]

и

[quote=/etc/X11/xorg.conf]
Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
   Load "drm"
   Load "dri"
   Load "dri2"
   Load "extmod"
   Load "dbe"
   Load "glx"
   Load "record"
EndSection

Section "Monitor"
	Identifier  "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:0:0"
        Option      "AccelMethod" "exa"
        Option      "DRI" "on"
        Option      "AGPMode" "4"
        Option      "ColorTiling" "on"
        Option      "EnablePageFlip" "on"
        Option      "AGPFastWrite" "yes"
        Option      "EXAVSync" "yes"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
[/quote]
ЧЯДНТ?

Ответ на: комментарий от KERNEL_PANIC

А у меня работают. Ты не из репозиториев пробовал? Просто драйвера очень активно разрабатываются, и их нужно ставить из последних «рук». У меня с ним все игры заработали (посмотри, я как-то создавал тему). В ауре наверняка есть что-то типо radeon-drivers-git. Ну, x11, mesa и dri тоже из гита нужно.

ktan ★★★ ()
Ответ на: комментарий от KERNEL_PANIC

Оно уже сдохло, и вроде как не шевелится. А вообще, почему тот вариант, что я привёл не подходит? Я, например, с ним спокойно играю в пенумбру, амнезию, квейк. Я бы на нём и остался, если бы не энергосбережение, а у тебя, судя по конфигу, станционарный, так что будет как раз.

ktan ★★★ ()

Так это проблемы fglrx+gnome3, погуглите - много чего вылезет. Или на свободные драйвера или уходить с gnome3.

vladkuzm ()
Ответ на: комментарий от vladkuzm

Поискал. Везде только описания проблемы, а решений не надблюдаю. Г3 я не брошу, та на ати не особо хочу откатываться, так что надеюсь на коллективный разум :)

KERNEL_PANIC ★★★ ()
Ответ на: комментарий от KERNEL_PANIC

Когда то давно, когда оно еще не умерло оно было быстрее в 2д чем xf86-video-ati, но с тех пор прошло уже много лет и даже самые стойкие некрофилы перестали им пользоваться + он не поддерживает твою видюху. А за 3д как отвечала меса так и продолжает отвечать.

Behem0th ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.