LINUX.ORG.RU

Ответ на: комментарий от Tanger

Как вариант, попробовать поставить тот, который есть. Возможно в нем не использовались возможности P4, если да - то заработает.

ymuv ★★★★
()

apt, rpm, да еще и изменить архитектуру?! Школоло или такой «тонкий» троллинг?

erfea ★★★★★
()

Напиши декомпилятор и перекомпилируй. Делов-то.

П.С. Если сырцы для этого пакета есть, считаю тса маразматиком.

damnemall
()
Ответ на: комментарий от erfea

предполагаю, что там noarch, ибо java.

Tanger ★★★★★
() автор топика
Ответ на: комментарий от damnemall

Если сырцы для этого пакета есть, считаю тса маразматиком.

Сырцы есть. Есть еще варианты?

Tanger ★★★★★
() автор топика
Ответ на: комментарий от elverion

> Так в чем проблема? i586 < pentium4.

В этом и проблема. Было бы наоборот, не было бы проблемы.

damnemall
()
Ответ на: комментарий от elverion

Эм. Действительно?

Я посчитал

Led

Да. HEX-редактор в руки - и вперёд

троллингом.

И где оно там указывается?

Tanger ★★★★★
() автор топика
Ответ на: комментарий от Tanger

> хочется убедится в том, что оно не исползует фичи pentium4.

Здесь только qemu поможет.

damnemall
()
Ответ на: комментарий от Tanger

предполагаю, что там noarch, ибо java.

хочется убедится в том, что оно не исползует фичи pentium4.

Признавайся! Школоло или упоротый?

erfea ★★★★★
()
Ответ на: комментарий от erfea

Там может быть и что-то еще.

Tanger ★★★★★
() автор топика
Ответ на: комментарий от elverion

Ткни носом. Читал RPM на википедии там нет. Только про стандарт названия.

Tanger ★★★★★
() автор топика

Так же интересует, как узнать используемую архитектуру. rpm -qip package.rpm не показывает.

apt-cache show package.rpm пишет что нет такого пакета.

Tanger ★★★★★
() автор топика
Ответ на: комментарий от Tanger

Так же интересует, как узнать используемую архитектуру. rpm -qip package.rpm не показывает.

slavaz@notebook ~/rpmbuild/RPMS/x86_64 $ rpm -qip mc-4.8.0-0.pre1.fc15.x86_64.rpm 
Name        : mc
Epoch       : 3
Version     : 4.8.0
Release     : 0.pre1.fc15
Architecture: x86_64

какая версия RPM?

P.S. HEX-редакторы не помогут, потому что при попытке изменения пакета контрольная сумма не сойдётся:

slavaz@notebook ~/rpmbuild/RPMS/x86_64 $ rpm -qip mc-4.8.0-0.pre1.fc15.x86_64.rpm 
ошибка: mc-4.8.0-0.pre1.fc15.x86_64.rpm: Header SHA1 digest: BAD Expected(37e75edba82bb3955ac58d3fb9b35d7c0f13bbfd) != (c9549cc00249257d54e3805cc57a4bf06697f43a)
ошибка: mc-4.8.0-0.pre1.fc15.x86_64.rpm: not an rpm package (or package manifest)

Можно, конечно, вычислить контрольную сумму заново и вбить так же хексом, но это путь к гландам в обход. Если даже всё получится (и со сменой архитектуры, и с контролькой), то вероятность того, что код, скомпилённый с оптимизацией под pentium4, не будет использовать инструкции pentium4 стремится к нулю.

Всё-таки придётся пересобрать пакет под правильную архитектуру с правильными опциями компилятора.

Slavaz ★★★★★
()
Ответ на: комментарий от Tanger

>Какая разница какой дистрибутив, если нужно поменять только поле архитектуры в пакете?

Ну, не хошь - как хош. 90% что я бы готовый вариант решения подсказал - без хакинга.

Led ★★★☆☆
()
Ответ на: комментарий от Tanger

>rpm 4.0.4.

Блин, ну так бы и сказал, что ALT

Led ★★★☆☆
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.