LINUX.ORG.RU

Кеширование в mplayer


0

2

Mplayer не хочет проигрывать матрешку с кучей аудио дорог. Ругань выглядит так:

[mkv] No video track found/wanted.
Matroska file format detected.
VIDEO: [avc1] 1920x1034 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
[ass] ENCA detected charset: ASCII
[ass] ENCA detected charset: ASCII
[ass] ENCA detected charset: ASCII
[ass] ENCA detected charset: ASCII
[ass] ENCA detected charset: ASCII
ID_DEMUXER=mkv
ID_VIDEO_FORMAT=avc1
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1920
ID_VIDEO_HEIGHT=1034
ID_VIDEO_FPS=23.976
ID_VIDEO_ASPECT=1.8569

Too many audio packets in the buffer: (4103 in 4127618 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
ID_AUDIO_FORMAT=8193
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=6
ID_START_TIME=0.00
ID_LENGTH=8030.24
ID_SEEKABLE=1
ID_CHAPTERS=32
Opening video filter: [ass auto=1]
Couldn't open video filter 'ass'.
ASS: cannot add video filter
==========================================================================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
ID_VIDEO_CODEC=ffh264vdpau
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 6 ch, s16le, 768.0 kbit/16.67% (ratio: 96000->576000)
ID_AUDIO_BITRATE=768000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=6
Selected audio codec: [ffdca] afm: ffmpeg (FFmpeg DTS)
==========================================================================
AO: [alsa] 48000Hz 6ch floatle (4 bytes per sample)
ID_AUDIO_CODEC=ffdca
[Mixer] No hardware mixing, inserting volume filter.
Starting playback...

Too many audio packets in the buffer: (4100 in 4124600 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Too many audio packets in the buffer: (4100 in 4124600 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Too many audio packets in the buffer: (4100 in 4124600 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Too many audio packets in the buffer: (4100 in 4124600 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Too many audio packets in the buffer: (4100 in 4124600 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Too many audio packets in the buffer: (4100 in 4124600 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Too many audio packets in the buffer: (4100 in 4124600 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Too many audio packets in the buffer: (4100 in 4124600 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Too many audio packets in the buffer: (4100 in 4124600 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Exiting... (End of file)
ID_EXIT=EOF 
Предполагая этот баг поменял демуксер с mkv на lavf, ругань изменилась на:
libavformat file format detected.
[matroska,webm @ 0x3383ec0] Too many streams
LAVF_header: av_open_input_stream() failed

Exiting... (End of file)
ID_EXIT=EOF 
Другие плееры проигрывают файл нормально, но у них нет vdpau. На стадии сборки матрешки косяков тоже никогда не было. Фильмы даже с бОльшим числом дорог проигрываются нормально, но в данном случае я имею 7 из 15 дорог в DTS с хорошим битрейтом. Поэтому я думаю что именно на стадии кеширования аудио дорог плееру и сносит башню, а как увеличить кеш именно для аудио я не знаю. Параметр "-cache" не влияет на кеширование аудио, его увеличение не помогло. Пересобирать файл с меньшим количеством дорог не выход, мне нужны все дороги до последней. О возможности подключать внешние дороги в плеере я тоже в курсе.

★★★★★

>Другие плееры проигрывают файл нормально, но у них нет vdpau.

VLC.

devl547 ★★★★★ ()

А сэр домочевский пробовал вообще отключить кеширование?

anonymous ()
Ответ на: комментарий от megabaks

Файл собрал на основе торрента с рутрекера 43020627 (хз можно ли давать полные ссылки). Фокус в том, что там mkv и часть дорог лежит отдельно, так вот файл без лишних дорог проигрывается нормально. Когда я добил остальные дороги в матрешку, mplayer перестал играть. Но на mkvmerge у меня никогда не было претензий. Стал смотреть что еще из коллекции моей изобилует дорогами и выяснил что есть у меня фильм с 17-ю дорогами, но они почти все в AC3 с низким битрейтом. А тут куча DTS с высоким.

Lordwind ★★★★★ ()
Ответ на: комментарий от nitz

Ну так и стоит родимый (v3.0.0), там же 3 утилиты, одна из которых mkvmerge. Но опции там такой нет.

Lordwind ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.