LINUX.ORG.RU

vmware-workstation + x11-forwarding


0

1

И это снова я со своими баранами.
По совету знакомого вместо vmware-server поставил все на тот же сервак с гентой и без иксов vmware-workstation. Проблема была в том, что нужны были иксы, чтобы рулить этим счастьем. Но их не было.
Поэтому, в sshd_conf разрешаем X11Forwarding, а на ноуте делаем «xhost +». После этого коннектимся по ссх с флагом -X, но ему не видится дисплей. Поэтому делаем export DISPLAY=«192.168.1.2:0.0» и запускаем злосчастную vmware. Профит!
Оно, конечно, ругается при запуске виртуалок на ненастроенный х-сервер, но это тема для дальнейших разбирательств.
Затем, вмваря устанавливает свои модули и я ее прибиваю, после чего опять пытаюсь запустить, но не тут то было:

hellheim ~ # vmware DISPLAY is not set, unable to open the VMware Workstation user interface. hellheim ~ # export DISPLAY="192.168.1.2:0.0" hellheim ~ # vmware xprop: unable to open display '192.168.1.2:0.0' No value set for `/desktop/gnome/interface/accessibility' xprop: unable to open display '192.168.1.2:0.0' No value set for `/desktop/gnome/interface/accessibility'

(vmware-modconfig:29852): Gtk-WARNING **: cannot open display: 192.168.1.2:0.0
На этом все. Разве что после пересборки некоторых пакетов перестало ругаться на xprop.
На винде с Xming все практически аналогично, только добавляет про no protocol specified.
Переустановка вмвари проблему не решает, в гугле тоже маловато полезного. Выручайте.

Deleted

> коннектимся по ссх с флагом -X
Попробуйте -Y.
Кстати, чему равен $DISPLAY сразу после подключения? По идее, ssh должна его сама выставить в правильное значение.

AITap ★★★★★ ()
Ответ на: комментарий от AITap
sm@thinkpad ~ >>> ssh -Y root@192.168.1.101 
Password: 
Last login: Thu May  5 12:42:32 MSD 2011 from 192.168.1.2 on pts/0
hellheim ~ # echo $DISPLAY

hellheim ~ # export $DISPLAY="192.168.1.2:0.0"
-bash: export: `=192.168.1.2:0.0': not a valid identifier
hellheim ~ # export DISPLAY="192.168.1.2:0.0"
hellheim ~ # echo $DISPLAY
192.168.1.2:0.0
hellheim ~ # vmware
No value set for `/desktop/gnome/interface/accessibility'
No value set for `/desktop/gnome/interface/accessibility'

(vmware-modconfig:4536): Gtk-WARNING **: cannot open display: 192.168.1.2:0.0
Deleted ()
Ответ на: комментарий от Deleted

> hellheim ~ # echo $DISPLAY



Вот это странно, ибо:

If the ForwardX11 variable is set to “yes” (or see the description of the -X, -x, and -Y options above) and the user is using X11 (the DISPLAY environment variable is
set), the connection to the X11 display is automatically forwarded to the remote side in such a way that any X11 programs started from the shell (or command) will go
through the encrypted channel, and the connection to the real X server will be made from the local machine. The user should not manually set DISPLAY. Forwarding of X11
connections can be configured on the command line or in configuration files.

Кстати, обратите внимание:
The DISPLAY value set by ssh will point to the server machine, but with a display number greater than zero. This is normal, and happens because ssh creates a “proxy” X
server on the server machine for forwarding the connections over the encrypted channel.


Иксовые приложения, конечно же, прекрасно запускаются из того же терминала?

AITap ★★★★★ ()
Ответ на: комментарий от AITap

честно говоря, на сервере не стоит xorg-server, так что я не могу сказать, запускаются ли другие иксовые приложения или нет.[br] У меня есть подозрение, что для подобного рода задач необходимы иксы как на локальной машине, так и на удаленной. Это так?

Deleted ()
Ответ на: комментарий от Deleted

> У меня есть подозрение, что для подобного рода задач необходимы иксы как на локальной машине, так и на удаленной. Это так?
По идее - только на локальной. На ней всё работает, да?

Попробуйте добавить к ssh от 1 до 3 флагов -v.

AITap ★★★★★ ()
Ответ на: комментарий от AITap

Вы не поверите, но с какого-то перепуга все стало работать: появился дефолтный $DISPLAY и вмваря запускается. Спасибо за помощь!

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.