LINUX.ORG.RU

xchat 2.0.5 >> 2.0.9


0

0

версия 2.0.5 с дистрибутива ASP 9.2 вместо русского выводила квадратики. Пробывал как обычно шрифты выставить в настройках, не помогло :( Порт при загрузке ставил как обычно. Скачал из инета версию 2.0.9, попытка сконфигурировать выдала в конце: ................... "xchat 2.0.9

Building GTK+ Interface .... : no Building TEXT Interface .... : no

PLUGINS: Perl: no Python: no TCL: no

mmx tinting ......... : yes XShm tinting ........ : no plugin interface .... : yes text backend ........ : pango nls/gettext ......... : no openssl support ..... : no ipv6 support ........ : no

The binary will be installed in /usr/local/bin

Warning: The GTK (GUI) frontend will not be built.

configure complete, now type 'make' and pray."

выполняю make, make install, пытаюсь запустить xchat - пишет что нету такой команды. Искал на винте, нету. Похоже дело в "Warning: The GTK (GUI) frontend will not be built.", только не как от этого предупреждения избавиться.

anonymous

Re: xchat 2.0.5 >> 2.0.9

Установил gtk. Теперь вот что получаю в результате конфига: "xchat 2.0.9

Building GTK+ Interface .... : yes Building TEXT Interface .... : no

PLUGINS: Perl: yes Python: no TCL: no

mmx tinting ......... : yes XShm tinting ........ : no plugin interface .... : yes text backend ........ : pango nls/gettext ......... : yes openssl support ..... : no ipv6 support ........ : no

The binary will be installed in /usr/local/bin

configure complete, now type 'make' and pray." Но после набора make: "make all-recursive make[1]: Вход в каталог `/tmp/xchat-2.0.9' Making all in po make[2]: Вход в каталог `/tmp/xchat-2.0.9/po' test -z "am.gmo az.gmo bg.gmo ca.gmo cs.gmo de.gmo el.gmo en_GB.gmo es.gmo et.gmo eu.gmo fi.gmo fr.gmo ja.gmo lt.gmo lv.gmo mk.gmo ms.gmo nl.gmo no.gmo pt.gmo ru.gmo sk.gmo sl.gmo sr.gmo sv.gmo uk.gmo wa.gmo zh_CN.gmo" || make am.gmo az.gmo bg.gmo ca.gmo cs.gmo de.gmo el.gmo en_GB.gmo es.gmo et.gmo eu.gmo fi.gmo fr.gmo ja.gmo lt.gmo lv.gmo mk.gmo ms.gmo nl.gmo no.gmo pt.gmo ru.gmo sk.gmo sl.gmo sr.gmo sv.gmo uk.gmo wa.gmo zh_CN.gmo make[3]: Вход в каталог `/tmp/xchat-2.0.9/po' rm -f am.gmo && : -c --statistics -o am.gmo am.po mv: невозможно выполнить stat для `t-am.gmo': No such file or directory make[3]: *** [am.gmo] Ошибка 1 make[3]: Выход из каталог `/tmp/xchat-2.0.9/po' make[2]: *** [stamp-po] Ошибка 2 make[2]: Выход из каталог `/tmp/xchat-2.0.9/po' make[1]: *** [all-recursive] Ошибка 1 make[1]: Выход из каталог `/tmp/xchat-2.0.9' make: *** [all] Ошибка 2" Что делать с этим уже не могу догадаться :(

anonymous ()

Re: xchat 2.0.5 >> 2.0.9

Извините за неформатированный текст. Вот эта строка у меня вызвала подозрение:

"mv: невозможно выполнить stat для `t-am.gmo': No such file or directory" Похоже где-то в выполняемом скрипте должно быть stat -t am.gmo, вместо stat t-am.gmo, если я прав, то где это искать? После этого следуют такие строки:

"make[3]: *** [am.gmo] Ошибка 1

make[3]: Выход из каталог `/tmp/xchat-2.0.9/po'

make[2]: *** [stamp-po] Ошибка 2

make[2]: Выход из каталог `/tmp/xchat-2.0.9/po'

make[1]: *** [all-recursive] Ошибка 1

make[1]: Выход из каталог `/tmp/xchat-2.0.9'

make: *** [all] Ошибка 2"

anonymous ()

Re: xchat 2.0.5 >> 2.0.9

Не собирается 2.0.9 у тебя нормально. Когда собирал 2.0.10, было тоже самое. Если не ошибаюсь просто не хватает gtk установленного. А квадратики у меня так и остались. Где-то читал что надо в gtk со шрифтами сделать. Я так и не нашел что надо сделать. Просто поставил какой-то старенький xchat и у меня все нормально стало.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.