LINUX.ORG.RU

serverless chat needed


0

1

не смогут ли добрые люди набросать краткий список serverless chat программ:

0.0) обязательные требования:
0.1) serverless;
0.2) язык программирования C,C++;
0.3) наличие в бинарном виде для win32;
0.4) GUI gtk<=2.4;qt=3.5.x,qt4=[4.3.x;4.5.x].

1.0) не обязательные требования:
1.1) file transfer
1.2) p2p (как в RetroShare);
1.3) наличие консольного интерфейса для linux;
1.4) присутствие в бинарном виде для Debian-lenny;
1.5) возможность сборки для Debian-lenny без сборки дополнительных
зависимостей, которых нет в официальном репозитории и backports.

2.0) замечания:
2.1) много ли проблем будет при сборке qt-4.5.x для Debian-lenny (хочу собрать RetroShare) ?;
2.2) Возможно ли перейти на Debian-6.0 если у меня /boot=/=JFS и есть ли там qt>=4.5.x?
(на lenny попытался сделать upgrade ядра до 2.6.32.x из backports - инсталлятор(dpkg)(?) захотел обязательно сменить UUID jfs партиций но чесно признался, что смену UUID без отмонтирования он подддерживает только для Ext3/Ext4)

>> Возможно ли перейти на Debian-6.0 если у меня /boot=/=JFS и есть ли там qt>=4.5.x?

Должно быть возможно, в принципе. Qt 4.6.3.

GotF ★★★★★ ()

По поводу serverless chat. Это в XMPP (XEP-0174), так что остаётся только выбрать клиенты, которые умеют это.

GotF ★★★★★ ()
Ответ на: комментарий от GotF

По поводу serverless chat. Это в XMPP (XEP-0174), так что остаётся только выбрать клиенты, которые умеют это.


да вот,как правило, клиентов под винду нет, либо есть только под винду.

вот и прошу список для расширения.

ps
про trix знал, но бинарников под винду не сделано,a vypress платный.

psps
directnet - гуй не собирается под debian с fltk из репозитория;
q-chat - глючит - одно соединение на один интерфейс;
openchatterbox - под винду нет сборки;
RetroShare - требует qt>=4.5;
icmpchat - собирается, но не работает;
bbechat - собирается, но вылетает при попытке запуска второго экземпляра.

botrops-schlegelii ★★ ()
Ответ на: комментарий от botrops-schlegelii

>> да вот,как правило, клиентов под винду нет, либо есть только под винду.

Pidgin есть и там и тут. Написан на Си, Link-Local умеет, что ещё-то нужно?

GotF ★★★★★ ()
Ответ на: комментарий от GotF

Link-Local

т.е. я могу указать в настройках аккаунта не pupkinvasja@jabber.ru, а
onotole@192.168.1.12 и добавить контакт типа unnamedplayer@192.168.1.45
и оно соединиться ?

умеет

Pidgin 2.7.3 (libpurple 2.7.3) ?

botrops-schlegelii ★★ ()
Ответ на: комментарий от botrops-schlegelii

Я не знаю как оно работает, если честно. Здесь описание фичи: http://xmpp.org/extensions/xep-0174.html

В настройках создания аккаунта надо выбрать протокол Bonjour.

Pidgin 2.7.3 (libpurple 2.7.3) ?

Он это умел ещё под именем Gaim :)

GotF ★★★★★ ()
Ответ на: комментарий от GotF

Bonjour:Не удаётся отправить сообщение, не удалось начать беседу.
хотя никнейм собеседника виден(тестирую на одной машине из-под двух аккаунтов и на одном и том же порте и на разных для каждого аккаунта).

botrops-schlegelii ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.