LINUX.ORG.RU

dhcpd [gentoo][wi fi]


0

1

Нужна помощь в настройке dhcp на раздачу ip подключаймым устройствам
Уже читал: https://help.ubuntu.com/community/WifiDocs/Adhoc, http://habrahabr.ru/blogs/linux/88281/ , http://linux.aldeby.org/ad-hoc-wireless-networking-in-linux.html, непомогло, сервер падает при ззапуске.
Вот /etc/dhcp/dhcpd.conf

ddns-update-style ad-hoc;
default-lease-time 3600;
max-lease-time 9000;
authoritative;
log-facility local7;
### ийпишник в сети 10.205.8.70 , он также весит на устройстве eth0
subnet 10.205.8.70 netmask 255.255.255.0 {
interface wlan0;
range 10.205.8.71 10.205.8.255;
option domain-name-servers 80.252.130.253; 
option routers 10.205.8.1;
option broadcast-address 10.205.8.0;
}

/etc/conf.d/dhcpd

# 
DHCPD_CONF="/etc/dhcp/dhcpd.conf"
DHCPD_IFACE="ppp0"

★★★★★

Ответ на: комментарий от deterok

Вообще хотел связать wlan0 с ppp0

DHCP != NAT. Это вообще разные вещи. Dhcpd просто раздаёт IP-адреса и настройки сети, он ничего ни с чем не связывает.

Deleted ()
Ответ на: комментарий от Deleted

Тогда что там писать в DHCPD_IFACE
И куда писать INTERFACES=«ppp0»

deterok ★★★★★ ()

Сделаем проще, вот скрипт который запускает интернет

ifconfig eth0 10.205.8.70 netmask 255.255.255.0
sleep 1
route add default gw 10.205.8.254
sleep 1
route add -host 10.255.255.254 gw 10.205.8.254
route add -net 80.252.130.248/29 gw 10.205.8.254
/etc/init.d/xl2tpd restart
sleep 2
route del default
sleep 1
route add default dev ppp0
Вот этим я запускаю wifi
ifconfig wlan0 down
iwconfig wlan0 mode ad-hoc
iwconfig wlan0 channel 1
iwconfig wlan0 Bit 54Mb/s
iwconfig wlan0 essid 'My Wifi'
ifconfig wlan0 10.42.43.1 netmask 255.255.255.0 up
iwconfig wlan0
ifconfig wlan0 up
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
Вот так пытаюсь настроить dhcp сервер
ddns-update-style ad-hoc;
default-lease-time 3600;
max-lease-time 9000;
#INTERFACES="eth0"
authoritative;
log-facility local7;
subnet 10.205.8.0 netmask 255.255.255.0 {
interface wlan0;
range 10.205.8.2 10.205.8.255;
option domain-name-servers 80.252.130.253;dns в локалке
option routers 10.205.8.70;
option broadcast-address 10.205.8.70;
Я знаю что я тут накуралесил, первый опыт с dhcp и wifi. Что я делаю не такая ?

deterok ★★★★★ ()
Ответ на: комментарий от deterok
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

в /etc/conf.d/dhcpd:

DHCPD_IFACE="wlan0"

zorgan ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.