LINUX.ORG.RU

Что за команды.


0

0

Здравствуйте! Debian. Пытался запустить gedit от рута, словил ошибки:

cannot open display:

и

No protocol specified

xhost: unable to open display ":0.0"

Выполнил команды, какие нагуглились (возможно ещё какие-то):

export DISPLAY=":0.0"

xhost +localhost

И проблема ушла. Подскажите, что это была за проблема, и каким пакетам сделать reconfigure чтобы починить, если возникнет снова. Спасибо!

>Подскажите, что это была за проблема

Очевидно, проблема в том, что не стоит от рута пускать gui-приложения.

anon_666 ()
Ответ на: комментарий от ptah_alexs

Спасибо, впредь буду использовать gksu.

Но пока из под юзера не сделаю «xhost +» проблема остается:

debian:/home/pjotar# gksu

No protocol specified

(gksu:7346): Gtk-WARNING **: cannot open display: :0.0

pjotar ()
Ответ на: комментарий от anon_666

/root/.bashrc выполняется при входе рутом в систему?

Вообще пляска пошла, видимо, с установки KDE или установки, а затем удаления дров для видео... Может быть можно переустановить или перенастроить пакеты, в которых происходит ошибка? Это GTK и Xorg?

Просто не хочу забивать костыль вставляя куда-то «xhost +».

Спасибо.

pjotar ()
Ответ на: комментарий от pjotar

>выполняется при входе рутом в систему?
Да.

костыль

Верно.

anon_666 ()
Ответ на: комментарий от anon_666

Спасибо!

Переустановил что-то, не помогло. В итоге временно добавил «xhost +» (что бы эта команда ни делала) в /home/myname/.bashrc

pjotar ()
Ответ на: комментарий от pjotar

Написали же, что нужно не под рутом запускать gksu gedit. Вылезет диалог ввода пароля рута, вводишь пароль и получаешь gedit с правами рута

aydar ★★★★★ ()
Ответ на: комментарий от pjotar

Дак, прочитайте же «man xhost» и «man xauth». Если коротко, то по умолчанию X-сервер не даёт подключаться к нему кому угодно, а только тем программам, которые могут себя авторизовать (взяв эту информацию из файла .Xauthority). А «xhost +» позволяет это всем.

mky ★★★★★ ()
Ответ на: комментарий от pjotar

> Вообще пляска пошла, видимо, с установки KDE или установки, а затем удаления дров для видео... Может быть можно переустановить или перенастроить пакеты, в которых происходит ошибка? Это GTK и Xorg?

это _не_ ошибка. тебе не нужно ничего переустанавливать, это вообще обычно не надо.
это нормальное поведение Х-сервера.

val-amart ★★★★★ ()
Ответ на: комментарий от val-amart

это нормальное поведение Х-сервера.

Ну можно и так сказать, да, но:

$ xhost 
access control enabled, only authorized clients can connect
SI:localuser:vga
SI:localuser:gdm
SI:localuser:root

В федоре за меня подумали :-).

vga ★★ ()
Ответ на: комментарий от anon_666

> Тогда пропишите xhost + в /root/.bashrc .

xhost + должен запускать тот пользователь, кто залогинен. А запуск от рута ничего не даст

cvs-255 ★★★★★ ()

Здравствуйте! Debian

Очень приятно)))) Прости не сдержался

GoNaX ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.