LINUX.ORG.RU

Проблема с обновлением (Archlinux)


0

0

Доброго времени суток. Возникли проблемы при обновлении:

[code]
[int13h@nastya tmp]$ sudo pacman -S xfce4-goodies
разрешение зависимостей...
проверка на взаимную несовместимость...

Цели (77): ristretto-0.0.22-1 squeeze-0.2.3-3 thunar-archive-plugin-0.2.4-6 thunar-media-tags-plugin-0.1.2-6 thunar-volman-0.3.80-1
xarchiver-0.5.2-1 libburn-0.8.2.pl00-1 l
libgweather-2.30.2-1 evolution-data-server-2.30.2.1-1 gnome-desktop-2.30.2-1 libcanberra-0.23-1 libart-lgpl-2.3.21-1
libgnomecanvas-2.30.1-1 gnome-mime-data-2.18.0-4 gnome-vfs-2.24.3-2 libbonobo-2.24.3-1 sg3_utils-1.29-1 parted-2.3-1
libatasmart-0.17-1 lsof-4.83-1 udisks-1.0.1-3 gnome-disk-utility-2.30.1-1 gvfs-1.6.2-1 libgnome-2.30.0-1
libbonoboui-2.24.3-1 gnome-panel-2.30.2-1 xfce4-xfapplet-plugin-0.1.0-6 xfce4-xkb-plugin-0.5.3.3-2 ffmpegthumbnailer-2.0.2-2
thunar-thumbnailers-0.4.1-3

Размер загружаемых файлов: 9,01 МБ
Размер устанавливаемых файлов: 178,61 МБ

Приступить к установке? [Y/n] y
:: Получение пакетов с extra...
libcanberra-0.23-1-i686 70,9K 1636,9K/s 00:00:00 [#################################################] 100%
libart-lgpl-2.3.21-1-i686 82,0K 2,5M/s 00:00:00 [#################################################] 100%
libgnomecanvas-2.30.1-1-i686 212,5K 96,3M/s 00:00:00 [#################################################] 100%
gnome-mime-data-2.18.0-4-any 703,6K 13,2M/s 00:00:00 [#################################################] 100%
ошибка: не удалось получить файл 'gnome-vfs-2.24.3-2-i686.pkg.tar.xz' из 192.168.0.100 : Service not available, closing control connection
ошибка: не удалось получить файл 'libbonobo-2.24.3-1-i686.pkg.tar.xz' из 192.168.0.100 : Service not available, closing control connection
ошибка: не удалось получить файл 'sg3_utils-1.29-1-i686.pkg.tar.xz' из 192.168.0.100 : Service not available, closing control connection
ошибка: не удалось получить файл 'parted-2.3-1-i686.pkg.tar.xz' из
предупреждение: не удалось получить некоторые файлы с extra
ошибка: не удалось завершить запрос (Service not available, closing control connection)
Обнаружены ошибки, пакеты не были обновлены.
[int13h@nastya tmp]$ sudo pacman -Syyu xfce4-goodies
:: Синхронизируются базы данных пакетов...
core 35,3K 956,7K/s 00:00:00 [#################################################] 100%
extra 455,2K 9,5M/s 00:00:00 [#################################################] 100%
community 368,0K 7,5M/s 00:00:00 [#################################################] 100%
:: Запускается полное обновление системы...
разрешение зависимостей...
проверка на взаимную несовместимость...

Цели (77): ristretto-0.0.22-1 squeeze-0.2.3-3 thunar-archive-plugin-0.2.4-6 thunar-media-tags-plugin-0.1.2-6 thunar-volman-0.3.80-1
xarchiver-0.5.2-1 libburn-0.8.2.pl00-1 libisofs-0.6.32-1 xfburn-0.4.3-1 xfce4-artwork-0.1-6 xfce4-battery-plugin-0.5.1-2
libunique-1.1.6-2 xfce4-clipman-plugin-1.1.3-1 xfce4-cpufreq-plugin-0.0.1-7 xfce4-cpugraph-plugin-0.4.0-2
xfce4-datetime-plugin-0.6.0-1 docbook-xml-4.5-4 docbook-xsl-1.75.2-1 gnome-doc-utils-0.20.1-1 gtk-doc-1.14-2
xfce4-dev-tools-4.6.0-1 xfce4-dict-plugin-0.6.0-1 xfce4-diskperf-plugin-2.1.0-5 xfce4-eyes-plugin-4.4.0-5
xfce4-fsguard-plugin-0.4.1-1 xfce4-genmon-plugin-3.2-1 xfce4-mailwatch-plugin-1.1.0-2 xfce4-messenger-plugin-0.1.0-6
xfce4-mount-plugin-0.5.4-3 libmpd-0.20.0-1 xfce4-mpc-plugin-0.3.5-1 xfce4-netload-plugin-0.4.0-5 xfce4-notes-plugin-1.7.6-1
libsexy-0.1.11-2 xfce4-notifyd-0.1.0-2 xfce4-playercontrol-plugin-0.3.0-1 xfce4-power-manager-0.8.5-1
xfce4-quicklauncher-plugin-1.9.4-4 libsoup-2.30.2-1 xfce4-screenshooter-1.7.9-1 xfce4-sensors-plugin-1.0.0-2
xfce4-smartbookmark-plugin-0.4.2-8 xfce4-systemload-plugin-0.4.2-5 xfce4-taskmanager-1.0.0-1 xfce4-timer-plugin-0.6-1
xfce4-verve-plugin-0.3.5-1 xfce4-wavelan-plugin-0.5.5-1 xfce4-weather-plugin-0.7.3-1 gnome-keyring-2.30.3-1
libgnome-keyring-2.30.1-1 libsoup-gnome-2.30.2-1 perl-xml-simple-2.18-2 icon-naming-utils-0.8.90-1 gnome-icon-theme-2.30.3-1
libgweather-2.30.2-1 evolution-data-server-2.30.2.1-1 gnome-desktop-2.30.2-1 libcanberra-0.23-1 libart-lgpl-2.3.21-1
libgnomecanvas-2.30.1-1 gnome-mime-data-2.18.0-4 gnome-vfs-2.24.3-2 libbonobo-2.24.3-1 sg3_utils-1.29-1 parted-2.3-1
libatasmart-0.17-1 lsof-4.83-1 udisks-1.0.1-3 gnome-disk-utility-2.30.1-1 gvfs-1.6.2-1 libgnome-2.30.0-1
libbonoboui-2.24.3-1 gnome-panel-2.30.2-1 xfce4-xfapplet-plugin-0.1.0-6 xfce4-xkb-plugin-0.5.3.3-2 ffmpegthumbnailer-2.0.2-2
thunar-thumbnailers-0.4.1-3

Размер загружаемых файлов: 7,97 МБ
Размер устанавливаемых файлов: 178,61 МБ

Приступить к установке? [Y/n] y
:: Получение пакетов с extra...
gnome-vfs-2.24.3-2-i686 738,4K 14,4M/s 00:00:00 [#################################################] 100%
libbonobo-2.24.3-1-i686 722,8K 14,9M/s 00:00:00 [#################################################] 100%
ошибка: не удалось получить файл 'sg3_utils-1.29-1-i686.pkg.tar.xz' из 192.168.0.100 : Service not available, closing control connection
ошибка: не удалось получить файл 'parted-2.3-1-i686.pkg.tar.xz' из
предупреждение: не удалось получить некоторые файлы с extra
ошибка: не удалось завершить запрос (Service not available, closing control connection)
Обнаружены ошибки, пакеты не были обновлены.
[int13h@nastya tmp]$
[/code]
Как видно, фтпшник отключает меня. Если делать pacman -S xxxxxx несколько раз (как на логах), то все ок - с трудом, но обновляется. Установлено свое зеркало (Vsftd 2.2.2), обновляюсь с него. Правда, при обновлении с других серверов, также возникала данная ошибка. Как я понимаю это wget начинает скачивать в несколько потоков, а сервер меня кикает?

★★★★★

Что мешает поставить закачку в один поток?

Можно еще вначале делать pacman -Swu, потом ставить.

Zodd ★★★★★ ()

а у меня такое вышло при обновлении frugalware:

root[Desktop]# pacman -Syu
:: Synchronizing package databases...
 frugalware-current is up to date
:: Starting local database upgrade...
resolving dependencies... done.
looking for inter-conflicts (5/5)                 [#######################] 100%

Targets: libcap-2.19-1 avahi-0.6.25-3 avahi-compat-0.6.25-3 avahi-glib-0.6.25-3
         hal-0.5.14-8

Total Package Size:   0.9 MB

Total Uncompressed Package Size:   5.4 MB

Proceed with upgrade? [Y/n] y


:: Retrieving packages from frugalware-current...
(1/5) libcap-2.19-1-x86_ [################] 100%      54K    29.7K/s  00:00:01
(2/5) avahi-0.6.25-3-x86 [################] 100%     337K   117.2K/s  00:00:02
(3/5) avahi-compat-0.6.2 [################] 100%      71K    35.6K/s  00:00:02
(4/5) avahi-glib-0.6.25- [################] 100%      37K    20.4K/s  00:00:01
(5/5) hal-0.5.14-8-x86_6 [################] 100%     438K    84.5K/s  00:00:05
checking package integrity... done.
checking for file conflicts (5/5)                 [#######################] 100%
error: failed to commit transaction (conflicting files)
libcap: /usr/lib64/libcap.a exists in filesystem
libcap: /usr/lib64/libcap.so exists in filesystem

errors occurred, no packages were upgraded.

root[Desktop]# 

кто виноват? криворукие ментейнеры или я?

uju ★★ ()

Проблема решилась раскоментированием

XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u в /etc/pacman.conf

int13h ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.