LINUX.ORG.RU

[ethtool] autoneg off выдает ошибку


0

0

Хочу ограничить скорость подключения со 100 до 10.

при вводе команды c параметром autoneg off

# ethtool -s eth0 speed 10 duplex full autoneg off
Cannot set new settings: Invalid argument
  not setting speed
  not setting duplex
  not setting autoneg

Если параметр убрать, то настройки скорости не меняются.

Если изменить на autoneg on то пропадает соединение, а ethtool eth0 выдает

Settings for eth0:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Full 
	Advertised auto-negotiation: Yes
	Speed: Unknown! (65535)
	Duplex: Unknown! (255)
	Port: Twisted Pair
	PHYAD: 0
	Transceiver: internal
	Auto-negotiation: on
	Supports Wake-on: g
	Wake-on: d
	Current message level: 0x00000000 (0)
	Link detected: no

То есть Speed и Duplex вообще не устанавливаются

Вот данные по карточке из lspci -v

Ethernet controller: Attansic Technology Corp. L2 100 Mbit Ethernet Adapter (rev a0)
	Subsystem: ASUSTeK Computer Inc. Device 8233
	Flags: bus master, fast devsel, latency 0, IRQ 2300
	Memory at fbfc0000 (64-bit, non-prefetchable) [size=256K]
	Expansion ROM at fbfa0000 [disabled] [size=128K]
	Capabilities: [40] Power Management version 2
	Capabilities: [48] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
	Capabilities: [58] Express Endpoint, MSI 00
	Capabilities: [6c] Vital Product Data <?>
	Capabilities: [100] Advanced Error Reporting <?>
	Kernel driver in use: atl2
	Kernel modules: atl2

Подскажите, куда копать дальше?

Ответ на: комментарий от nnz

Пробовал. Там вообще глухо.

sudo mii-tool -v
eth0: negotiated 100baseTx-FD, link ok
  product info: vendor 00:13:74, model 2 rev 2
  basic mode:   autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  link partner: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control

sudo mii-tool -A 10baseT-FD eth0
restarting autonegotiation...

sudo mii-tool -v
eth0: negotiated 100baseTx-FD, link ok
  product info: vendor 00:13:74, model 2 rev 2
  basic mode:   autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  link partner: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control

sudo mii-tool -F 10baseT-FD eth0

sudo mii-tool -v
eth0: negotiated 100baseTx-FD, link ok
  product info: vendor 00:13:74, model 2 rev 2
  basic mode:   autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  link partner: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control
yaroslav ()

В принципе проблема частично решилась, а именно: на домашней сетке корректно работали и ethtoll, и mii-tool. ИМХО, на работе не получалось из-за того, что вся сеть работает под управлением оффтопик7.

yaroslav ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.