LINUX.ORG.RU

Как поднять Wi-Fi встроенными средствами?


0

0

Други помогите поднять Wi-Fi сеть. Задача такая: 1. Wi-Fi сеть встроенными средствам,без участия KDE или любых других иксов.

2. Нужно чтобы сеть поднималась автоматом, при загрузке компа.

3. Карточка на чипе rt61pci будет работать в качестве клиента.

4. Кодровка WEP 64 разрядная (такая уж установлена на точке доступа и с этим ничего нельзя поделать).

Драйвера уже были включены в ядро, также как и прошивка wirmware для этой беспроводной сетевухи.

Вот мои конфиги:

rc.inet1.conf

# /etc/rc.d/rc.inet1.conf
IFNAME[4]="RT61PCI"
IPADDR[4]="192.168.1.4"
NETMASK[4]="255.255.255.0"
WLAN_ESSID[4]="Satman_WLAN"
WLAN_MODE[4]="Managed"
WLAN_RATE[4]="11M"
WLAN_CHANNEL[4]="3"
WLAN_KEY[4]="Z4A9B"

rc.wireless.conf

#
VERBOSE=1
case "$HWADDR" in
# RaLink RT2561/RT61 rev B 802.11g
*)
    INFO="RaLink RT2561/RT61 rev B 802.11g"
    ESSID="Satman_WLAN"
    MODE="Managed"
    FREQ=""
    CHANNEL="3"
    RATE="11M"
    KEY="Z4A9B"
    #RTS=""
    ########## Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
    IWCONFIG=""
    ########## iwspy parameters : + 01:23:45:67:89:AB
    IWSPY=""
    ########## iwpriv parameters : set_port 2, set_histo 50 60
    IWPRIV=""
    ;;
esac

Что еще надо? Попробовал выполнить iwlist wlan0 scan, точку доступа увидел. Пинги не ходят. Подозреваю что в сеть не пускает из за WEP ключей.

а если вручную подключиться?

iwconfig wlan0 essid имя_точки_доступа
iwconfig wlan0 key ключ
dhclient wlan0

JB ★★★★★ ()

Кстати, можешь сказать, работает ли у тебя эта карточка в режиме мастера или адхок? Т.е., что скажет iwconfig wlan0 mode master?
У меня её не получилось заставит работать точкой доступа, вроде бы нужно компилять драйвер от производителя.

lyset ★★★ ()

IFNAME[4]=«RT61PCI»

Ну тут явно IFNAME[4]=«wlan0» Вобщем мой рабочий конфиг:

/etc/rc.d/rc.inet1.conf:
IFNAME[4]="wlan0"
IPADDR[4]="192.168.128.2"
NETMASK[4]="255.255.255.0"
#USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]="psap"
WLAN_MODE[4]="Managed"
#WLAN_RATE[4]="54M auto"
WLAN_RATE[4]="54M"
WLAN_CHANNEL[4]="auto"
#WLAN_KEY[4]="zk8ridRo77"
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"

sudo cat /etc/wpa_supplicant.conf:
 
# See /usr/doc/wpa_supplicant-0.6.9/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
#country=US

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
  ssid="psap"
  proto=WPA RSN
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk="MY_KEY"
  priority=10
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
network={
  key_mgmt=NONE
  priority=0
}

После sudo /etc/rc.d/rc.inet1 wlan0_restart получаю
dmesg

wlan0: direct probe to AP 1c:af:f7:49:77:16 (try 1)
wlan0: direct probe responded
wlan0: authenticate with AP 1c:af:f7:49:77:16 (try 1)
wlan0: authenticated
wlan0: associate with AP 1c:af:f7:49:77:16 (try 1)
wlan0: RX AssocResp from 1c:af:f7:49:77:16 (capab=0x431 status=12 aid=1)
wlan0: AP denied association (code=12)
wlan0: deauthenticating from 1c:af:f7:49:77:16 by local choice (reason=3)
wlan0: direct probe to AP 1c:af:f7:49:77:16 (try 1)
wlan0: direct probe responded
wlan0: authenticate with AP 1c:af:f7:49:77:16 (try 1)
wlan0: authenticated
wlan0: associate with AP 1c:af:f7:49:77:16 (try 1)
wlan0: RX AssocResp from 1c:af:f7:49:77:16 (capab=0x431 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
cfg80211: Calling CRDA for country: DE
cfg80211: Current regulatory domain updated by AP to: DE
    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    (2402000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
По /etc/wpa_supplicant.conf глянь man wpa_supplicant.conf секция 4.

tux2002 ()
Ответ на: комментарий от tux2002

Спасибо. Всё заработало! wpa_supplicant.conf править не пришлось. Так как я WEP шифрование с фильтрацией по MAC адресам использую.

Humaxoid ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.