LINUX.ORG.RU

Установка пакетов в Debian


0

0

Проблема такая: установил Debian Lenny с первого диска, дальше хотел установить midori audacous и т д но они в разделе sid

подскажите, как можно устанавливать пакеты из sid, чтобы они не «тянули» за собой обновления других пакетов до sid.

Лучше использовать бэкпорты. Ибо sid — «нестабильный» репозиторий и зависимости там могут быть неустранимыми. А вообще, можно поставить 6.0, если мегастабильность не принципиальна.

vkos ★★ ()

audacious есть и в lenny:
http://packages.debian.org/lenny/audacious

подскажите, как можно устанавливать пакеты из sid, чтобы они не «тянули» за собой обновления других пакетов до sid.


ну есть такие варианты:
1. cобирать пакеты самому для lenny (и что не всегда технически возможно)
(или найти из сторонних реп бекпорты).
2. просто обновить систему до sid.

elipse ★★★ ()
Ответ на: комментарий от vkos

То есть, как я понял, нельзя установить из sid один пакет, нужно всю систему до sid обновлять?

подскажите пожалуйста, что в sources.list прописать для backports

grisha_ektb ()
Ответ на: комментарий от grisha_ektb

>То есть, как я понял, нельзя установить из sid один пакет, нужно всю систему до sid обновлять?

У меня не дебиан, но думаю, что да.

подскажите пожалуйста, что в sources.list прописать для backports

Вот тут (http://backports.org/dokuwiki/doku.php?id=instructions) инструкции. (если кратко, то добавить deb http://www.backports.org/debian lenny-backports main contrib non-free)

vkos ★★ ()
Ответ на: комментарий от grisha_ektb

>То есть, как я понял, нельзя установить из sid один пакет, нужно всю систему до sid обновлять?

1. Не всю, а только те, что требуются по зависимости. Если повезет, то их будет не много, но если что-то большое захотел поставить, то скорее всего многие пакеты захотят по зависимостям тоже обновиться. Что не безопасно.

2. Судя по всему ты используешь debian на десктопе - оставаться на stable (lenny) нет ни одной причины, смело обновляйся до testing (squeeze) - тут тебе и относительно свежие пакеты + достаточная стабильность. sid пока не трогай - тут что-то поломаться может чаще.

3. Еще погугли про apt-pinning - это такой механизм управления приоритетами репозиториев.

Turbid ★★★★★ ()

Никак. Либо использовать бекпорты, либо обновляться до sid полностью (есть ещё testing, если что).

AITap ★★★★★ ()
Ответ на: комментарий от Turbid

> 2. Судя по всему ты используешь debian на десктопе - оставаться на stable (lenny) нет ни одной причины, смело обновляйся до testing (squeeze) - тут тебе и относительно свежие пакеты + достаточная стабильность. sid пока не трогай - тут что-то поломаться может чаще.

Бггг , какая чудная мальчуковая бредятина.

elipse ★★★ ()
Ответ на: комментарий от elipse

+1 Достаточная стабильность для кого? У меня иксы глючили с открытым драйвером ати. Пришлось ставить иксы из анстейбла. Лучше стабильный ставь, а свежий софт поставь из тестинга или из ппа.

Serge ()
Ответ на: комментарий от Turbid

> нет ни одной причины,

4.2
ну на вскидку:
1. стабильная система ( как у Бога за пазухой)
2. повторяемость установок
3. возможность работы fglrх на старых карточках ati.
...

смело обновляйся до testing

testing не имеет секюрных обновлений.
и что ты знаеш о работе Britney ?

достаточная стабильность


а прежде чем наплевательски относится (и другим советовать подобное)
к большой проделанной работе в стабильном Debian, (4-й раз тут) уже процитирую
главного мантейнера Gnome в Debian :


Le mercredi 21 octobre 2009 à 16:35 +0300, elipse a écrit :

Obviously, you have no desire to upgrade nautilis in testing.

There are forces only meaningless resistance.


You are using a Debian testing? :))



OK, so this must be about some bug that’s only here in testing.

I’ll only have to re-explain what I have already explained to other
people.
* Do not use testing for a desktop. Use stable or unstable, not
testing.
* I’m not in control of testing migration.
* Testing isn’t meant to be usable. Don’t use testing for a
desktop.
* Things like this always happen in testing. Bugs can be fixed
quickly in unstable, they cannot be in testing since there is
always some delay before packages can migrate.
* DO NOT USE TESTING for your desktop.

Kthxbye,
--
."`. Josselin Mouette
: :' :
`. `' “I recommend you to learn English in hope that you in
`- future understand things” — Jörg Schilling

Заметь, что кеды и рядом не валялись по стабильности с Gnome.
А хотя человек, мог и навесить лоровский стандартный комплект лапши на уши: УВР, ЧЯНД, ровняйте руки в тисках ... ))

elipse ★★★ ()
Ответ на: комментарий от elipse

Безусловно, testing чаще замечательно работает - но, до заморозки
стабильность и надежность работы приложений ничем не гаранитирована,
а вторитетное надувание щек от лица всего дистра - ну, это дело такое ...
молодецкое ))

elipse ★★★ ()
Ответ на: комментарий от elipse

> 1. стабильная система ( как у Бога за пазухой)
субъективно же.

2. повторяемость установок

wtf?!

3. возможность работы fglrх на старых карточках ati.

ты еще какую-нить isa-звуковушку вспомни. и что ты будешь приводить в пример после выхода очередного stable?

testing не имеет секюрных обновлений.

я в своем посте писал про условие что чувак использует систему как десктоп. там эти обновления никому не сдались. как про неуловимого джо. + откуда у тебя гарантии, что мейнтейнеры быкпортнули все секюрити-фиксы из свежего app_name 1.4 в app_name 0.5 из stable?

(4-й раз тут) уже процитирую главного мантейнера Gnome в Debian

это мнение одного мейнтейнера. зуб даю что с ним многие его коллеги не согласятся.

I’m not in control of testing migration

если это его политика - хреново вам гномерам.

но раз уж ты обрекаешь простого пользователя выбирать мужду stable и sid, то я буду рекомендовать sid, ибо пользоваться софтом 2-летней давности - жесть неимоверная. если это оправданно для серверов и рабочих станций в продакшене, то для обычного хомячка - дискредитация linux как удобной и современной системы.

Заметь, что кеды и рядом не валялись по стабильности с Gnome.

ой, не начинай.

и еще, можно подумать что testing тестируют одни мейнтейнеры и роботы. если бы не армия пользователей, регулярно отписывающихся о багах, то есть мнение что багзилла перед очередным релизом была бы чуть менее чем пустая, что положительно сказалось бы на отсутствие традиционных задержек, но как бы тогда на Debian смотрели люди из продакшена?

если средний пользователь пару раз отпишется в багзиллу о том, что его плеер три раза в месяц сегфолтится, то ничего с ним не случится, на крайний случай откатится. а вот потерянная совместимость с новым API какого-нить last-fm его опечалит.

Turbid ★★★★★ ()
Ответ на: комментарий от thunar

>вьюноша бледный со взором багряным

у бородача увел жену, теперь тот рогами...

Turbid ★★★★★ ()
Ответ на: комментарий от Turbid

>субъективно же.
а эта :

то для обычного хомячка - дискредитация linux как удобной и современной системы.

Апогей поцанской обьективности был ? ))

Вот RH (ну и MS) не могут позволить себе подобный гон за номерками пакетов программ и еще как-то зарабатывают деньги.))

ибо пользоваться софтом 2-летней давности - жесть неимоверная.


И что будет ? Поцаны во дворе засмеют ?
Может дети хуже будут от этого получатся?
ps: Забавно, как себе придумывают комплексы и манечки.


и еще, можно подумать что testing тестируют одни мейнтейнеры и роботы. если бы не армия пользователей, регулярно отписывающихся о багах, то есть мнение что багзилла перед очередным релизом была бы чуть менее чем пустая, что положительно сказалось бы на отсутствие традиционных задержек, но как бы тогда на Debian смотрели люди из продакшена?


Ну а это к чему уже ?
Тестировать дистр и использовать как основной десктоп - это немного разные вещи.
А большая половина хронических задротов-обновленцев не сможет и двух слов написать в багзиллу. Коматозным бредом и так забита уже багзила убунты. Нафиг надо такое нашествие в Debian .


а вот потерянная совместимость с новым API какого-нить last-fm его опечалит.


какой-то бред и каша: прдакшн, last-fm, плеер три раза в месяц сегфолтится
...

это мнение одного мейнтейнера. зуб даю что с ним многие его коллеги не согласятся


Зубов так на все не хватит.

Короче, фактов у тебя нет.
А сверблячку в заднице по новым кедам как незыблемый какой-то закон природы подсовываешь.




elipse ★★★ ()
Ответ на: комментарий от elipse

>Вот RH

Рекомендуют ставить хомячкам федорку - в лучшем случае подобие сида+экспериментала

Забавно, как себе придумывают комплексы и манечки.


Новый софт в большинстве своем удобней. Но за удобство платишь ценой стабильности. Нужно искать баланс. Testing - не самый плохой здесь вариант.


Тестировать дистр и использовать как основной десктоп - это немного разные вещи.


Как можно тестировать софт, не работая в нем? Юнит-тесты не везде работают.

Turbid ★★★★★ ()
Ответ на: комментарий от Turbid

>Лучше стабильный ставь, а свежий софт поставь из тестинга или из ппа.

собственно в этом и проблема, как поставить из тестинга, не обновляясь до него?

grisha_ektb ()
Ответ на: комментарий от Turbid

>Не всю, а только те, что требуются по зависимости. Если повезет, то их будет не много,

лучше не рисковать и начинать с бэкпортов (благо там много чего есть)

annulen ★★★★★ ()
Ответ на: комментарий от grisha_ektb

>собственно в этом и проблема, как поставить из тестинга, не обновляясь до него?


3. Еще погугли про apt-pinning - это такой механизм управления приоритетами репозиториев.

Turbid ★★★★★ ()
Ответ на: комментарий от AITap

>>Никак. Либо использовать бекпорты, либо обновляться до sid полностью (есть ещё testing, если что).

не надо обновляться до sid полностью.

alex_custov ★★★★★ ()
Ответ на: комментарий от grisha_ektb

добавить репозитории squeeze, добавить пин для squeeze, чтобы он был менее приоритетен, чем lenny.

alex_custov ★★★★★ ()
Ответ на: комментарий от alex_custov

Насчёт официальной документации не помню, но в LOR FAQ это точно сказано:

В случае использования testing можно (на свой страх и риск) смешивать пакеты из testing, unstable, experimental репозиториев. Для stable ветки подобным заниматься не следует, лучше всего воспользоваться репозиторием backports.

AITap ★★★★★ ()
Ответ на: комментарий от AITap

в backports бывают косяки похлеще чем в testing. Из последнего - alsa была собрана без deprecated символов, из-за чего падал skype на чистом профиле. А вообще, я с ветки Etch сижу на смеси stable+testing, и ничего (сейчас Lenny+Squeeze). Если имеются строгие зависимости одной программы от версии другой, то они как правило указаны, и ничего не поломают. Сидеть на смеси stable+testing как правило безопасно. Ближе к релизу testing-a можно переходить на него полностью.

alex_custov ★★★★★ ()

Проще обновиться. Хотя через aptitude можно указывать из какого репозитория ставить конкретный пакет с зависимостями, какие опции не помню. Но будь готов к поломкам

DNA_Seq ★★☆☆☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.