LINUX.ORG.RU

kernel-2.4.23


0

0

С Наступающим всех! Помогите понять что не так. Собирается всё без ошибок и работает тоже, но при выпонении FIREWALL скрипта ругается! iptables: Invalid argument

Было: kernel-2.4.21 - под ним этот скрипт работает без проблем и ругательств. iptables-1.2.7a (от MDK) iptables-devel-1.2.7a (от ASP)

Обновился: kernel-2.4.23 + patch openwall (2.4.23-ow1) iptables-1.2.9 (от MDK) iptables-devel-1.2.9 (из iptables-1.2.9.tar.gz в usr/local/iptables-devel такимми действиями: make KERNEL_DIR=../../linux, потом make instal-devel и нужные пакеты легли в /usr/local/iptables-devel)

Врезультате получил: kernel-2.4.21 kernel-2.4.23-ow1 iptables-1.2.9 iptables-devel-1.2.9

Если я загружаюсь под 2.4.23-ow1 и запускаю FIREWALL скрипт то я получаю сообщение iptables: Invalid argument Но приэтом все правила грузятся и вроде работают! А когда перезагружаюсь под старое ядро 2.4.21 и запускаю фаервол скрипт такого сообщения нет!

Ради интереса сделал под 2.4.21 #iptables -nL >> old_kernl

под 2.4.23-ow1 #iptables -nL >> new_kernl

Размеры полученных файлов одинаковы!

Вчём может быть проблема?

anonymous

Re: kernel-2.4.23

методом деления скрипта пополам можно найти заветную строчку...

grustnoe ★★ ()

Re: kernel-2.4.23

а дистр какой? нах ставить пакеты от разных дистрибутивов?

anonymous ()
Ответ на: Re: kernel-2.4.23 от anonymous

Re: Re: kernel-2.4.23

Решил - пересборкой rpm пакета iptables

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.