LINUX.ORG.RU

netsukuku проблема


0

0

http://ru.wikipedia.org/wiki/Netsukuku

Проблема с этой программой

Ставил по иструкции отсюда http://netsukuku.freaknet.org/index.php?pag=documentation&file=howto/pyntk_howto

/home/arpunk/mybins/bin/python2.5 ntkd «n='wlan0'» /root/ntk/pyntk/ntk/network/linux/adapt.py:32: Warning: 'with' will become a reserved keyword in Python 2.6 Traceback (most recent call last): File «ntkd», line 31, in <module> from ntk.ntkd import NtkNode File «/root/ntk/pyntk/ntk/ntkd.py», line 22, in <module> import ntk.core.radar as radar File «/root/ntk/pyntk/ntk/core/radar.py», line 42, in <module> import ntk.lib.rpc as rpc File «/root/ntk/pyntk/ntk/lib/rpc.py», line 83, in <module> from ntk.network.inet import sk_set_broadcast, sk_bindtodevice File «/root/ntk/pyntk/ntk/network/__init__.py», line 28, in <module> backend = __import__('ntk.network.%s.adapt' % NETWORK_BACKEND, {}, {}, ["]) File «/root/ntk/pyntk/ntk/network/linux/adapt.py», line 32 with open(path, 'w') as f: ^ SyntaxError: invalid syntax

А под обычным питоном она идёт? Такое ощущение что ошибка из-за неправильной версии пистона.

Nao ★★★★★ ()
Ответ на: комментарий от Nao

А под обычным вот так:

python ntkd Traceback (most recent call last): File «ntkd», line 30, in <module> from ntk.lib.micro import allmicro_run File «/root/ntk/pyntk/ntk/lib/micro.py», line 21, in <module> import stackless ImportError: No module named stackless

rpostra1 ()

Было бы неплохо отформатировать как-то. Но исходя из следующих обрывков лога:

/home/arpunk/mybins/bin/python2.5

line 32 with open(path, 'w') as f: ^ SyntaxError: invalid syntax


можно сказать, что версия питона нужна не меньше 2.6, поскольку в 2.5 with нужно было импортировать. По указанной ссылке используется 2.5, но сам howto уже довольно старый, и код в 2.5 уже не работает.

Laz ★★★★ ()

А с новым питоном

root@mebius:/root/ntk/pyntk# /home/arpunk/mybins/bin/python2.6 ntkd «n='dummy0'» dbg=9

Никакого вывода в консоль , хотя должна показатся отладка , просто молча не работает

rpostra1 ()
Ответ на: комментарий от rpostra1

> python ntkd Traceback (most recent call last): File «ntkd», line 30, in <module> from ntk.lib.micro import allmicro_run File «/root/ntk/pyntk/ntk/lib/micro.py», line 21, in <module> import stackless ImportError: No module named stackless

очевидно, ему нужен стеклесс (stackless.com)

val-amart ★★★★★ ()

> /home/arpunk/mybins/bin/python2.5 ntkd «n='wlan0'» /root/ntk/pyntk/ntk/network/linux/adapt.py:32: Warning: 'with' will become a reserved keyword in Python 2.6 Traceback (most recent call last): File «ntkd», line 31, in <module> from ntk.ntkd import NtkNode File «/root/ntk/pyntk/ntk/ntkd.py», line 22, in <module> import ntk.core.radar as radar File «/root/ntk/pyntk/ntk/core/radar.py», line 42, in <module> import ntk.lib.rpc as rpc File «/root/ntk/pyntk/ntk/lib/rpc.py», line 83, in <module> from ntk.network.inet import sk_set_broadcast, sk_bindtodevice File «/root/ntk/pyntk/ntk/network/__init__.py», line 28, in <module> backend = __import__('ntk.network.%s.adapt' % NETWORK_BACKEND, {}, {}, ["]) File «/root/ntk/pyntk/ntk/network/linux/adapt.py», line 32 with open(path, 'w') as f: ^ SyntaxError: invalid syntax

а это вывод со стеклесса, да?
очевидно, хау-ту старый, новый код (который ты согласно интрукции взял с свн) не содержит from __future__ import with_statement. или добавь эту строку в исходник, или просто попробуй более свежий стеклесс, например http://www.stackless.com/binaries/stackless-264-export.tar.bz2

val-amart ★★★★★ ()

С новым питоном внешне ошибок нет . Просто не работает: запускаю и никакого вывода в консоль ,хотя должна появится отладка ...

rpostra1 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.