LINUX.ORG.RU

Не собирается mplayer c vdpau


0

0

Имеется Ubuntu 9.04 x86_64. Делаю:

svn co svn://svn.mplayerhq.hu/mplayer/trunk mplayer
cd mplayer
./configure svn://svn.mplayerhq.hu/mplayer/trunk
make
В итоге получаю:
$ make
vidix/pci_db2c.awk vidix/pci.db 1
make: execvp: vidix/pci_db2c.awk: Permission denied
cc -Wundef -Wdisabled-optimization -Wno-pointer-sign -Wdeclaration-after-statement -std=gnu99 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -O4 -march=native -mtune=native -pipe -ffast-math -fomit-frame-pointer -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -Ilibdvdread4 -I.  -D_REENTRANT  -D_REENTRANT   -I/usr/include/freetype2   -c -o libvo/vo_vdpau.o libvo/vo_vdpau.c
In file included from libvo/vo_vdpau.c:46:
./libavcodec/vdpau.h:76: error: expected specifier-qualifier-list before 'VdpPictureInfoMPEG4Part2'
libvo/vo_vdpau.c: In function 'create_vdp_mixer':
libvo/vo_vdpau.c:495: error: 'VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L1' undeclared (first use in this function)
libvo/vo_vdpau.c:495: error: (Each undeclared identifier is reported only once
libvo/vo_vdpau.c:495: error: for each function it appears in.)
libvo/vo_vdpau.c: In function 'create_vdp_decoder':
libvo/vo_vdpau.c:580: error: 'VDP_DECODER_PROFILE_MPEG4_PART2_ASP' undeclared (first use in this function)
make: *** [libvo/vo_vdpau.o] Ошибка 1
Без VDPAU собирается. В чем может быть проблема?

Ответ на: комментарий от Sylvia

Думаю перейти на 9.10. Но перед переходом решил проверить, собираются нужные мне программы или нет. В свое время (месяца 3 назад), когда ставил 9.04 mplayer собрался без проблем. Все-таки думаете, что проблем со сборкой под 9.10 не будет?

Basile ()
Ответ на: комментарий от Basile

месяца три назад - возможно, а пару недель назад под 9.04 у меня mplayer из svn забраковал при конфигурировании часть библиотек с кодеками как слишком старые, и vdpau из репозиториев ему тоже не понравился, под 9.10 проблем быть не должно наверное, оно достаточно свежее еще.

Sylvia ★★★★★ ()
Ответ на: комментарий от Sylvia

Поставил Ubuntu 9.10, установил последний драйвер с сайта nvidia, взял последние патчи для mplayer... mplayer собрался. Сложнее всего было найти все зависимые пакеты.

А по поводу 9.04 нашел вот такое интересное письмо: http://lists.mplayerhq.hu/pipermail/mplayer-users/2009-December/078406.html

Оффтоп: как отредактировать первое сообщение? Там я немного накосячил: должно быть: ./configure --enable-vdpau

Basile ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.