LINUX.ORG.RU

Проблема с socket (не сетевым)


0

0

Здравствуйте! Некоторое время назад всё работало нормально. Я даже удивлялся. Но в какой-то момент (уже не помню какой, после какого-то обновления) всё стало глючить. Не падать, а именно глючить. Представлю примерный план:
1) Компьютер включается. Всё как обычно. Только автологин работает через раз (раньше работал всегда). Загружается КДЕ4.
2) Тут начинается всё самое веселое. Plasma всячески не дает работать. При попытке поиска программ в меню через kickoff Плазма виснет: панели не работают вообще, после перетаскивания окон прежнее место занимает кусок окна (по типу того, что происходит, когда виснет explorer.exe в Альтернативной ОС). Через полминуты-минуту все отвисает. Также наблюдаются произвольные зависания, непонятно от чего.
3) При работе в Konsole он тоже произвольно зависает. Также виснет при автодобавлении через Tab. И также отвисает через некоторое время.
4) После убивания Плазмы и повторного её запуска она не запускается.
Проходит примерно 10 минут после запуска. Выскакивает окошко с сообщением о том, что "Службы КДЕ" (вроде бы это kded4) упала. Не обращаю внимание на окошко, просто закрываю его. И тут всё начинает работать нормально! и Плазма не виснет, и запускается, и Консоле отлично работает. Сначала подумал, что это глюк КДЕ4 - чего от него только не ожидаешь! Но сейчас случайно запустил Teeworlds в терминале, ещё до "волшебного" лечащего сообщения о падении служб КДЕ. Они не запускались, в конце терминала появляется надпись socket(): Семейство адресов не поддерживается протоколом (socket(): Address family not supported by protocol с английской локалью). После "волшебного" сообщения такой строки не появляется и запуск идет нормально. С Qmmp то же самое - при попытке проигрыванию любого файла появляется та же строка, также весь интерфейс плеера превращается в серый прямоугольник. После "волшебного" сообщение такого нету. Сносил .kde4 - не помогает. Также начал падать при загрузке E17 и глючить звук. Пока что виню ядро 2.6.30-rc8 - в репозитариях новее нет. Но если кто знаком с такой проблемой - просьба все равно помочь.
P.S. OpenSuse 11.2 Milestone 1+2.
P.P.S. Гугление не помогло.
P.P.P.S. Можете спокойно требовать дополнительных данных.

★★★★

Re: Проблема с socket (не сетевым)

>>>>>Пока что виню ядро 2.6.30-rc8 - в репозитариях новее нет
>>>ядро 2.6.30-rc8
>>2.6.30-rc8
>rc8

Ну дык

>в репозитариях новее нет

Тебе не новее а старее надо

ZZaiatSS ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.