LINUX.ORG.RU

Нет соединения с MySQL.


0

0

В общем дистрибутив на ядре Слаки.Ставил MySQL слаковым пакетом, через mpkginstall blah.tgz, далее прописал /usr/bin/mysql_install_db, всё ok, ставлю права: chown -R mysql.mysql /var/lib/mysql , chown -R mysql.mysql /var/run/mysql . Запускаю: /etc/rc.d/rc.mysqld start .Выдаёт: # nohup: redirecting stderr to stdout Starting mysqld daemon with databases from /var/lib/mysql

После чего пробую коннектиться к БД через разные менеджеры, Навикатом, к примеру.Пишет, что нет коннекта.Выключил роутер (думал порт закрыты), то же самое.Тут щас тему почитал, человек писал, что "лол.это не ошибка, а нормальный старт мускуля".Может и так, но подключаться я не могу почему-то.Если после стартования писать "mysql", то могу импортировать/добавлять базы и таблицы скульные из терминала.В общем помогите, кто сталкивался :).

Re: Нет соединения с MySQL.

так там, помнится, надо в /etc/my.cnf включать, что бы mysqld в сеть смотрел, а не только через файловые сокеты общался. конкретно — смотри параметр „port“.

P.S. или меня жестоко глючит.

dmiceman ★★★★★ ()
Ответ на: Re: Нет соединения с MySQL. от dmiceman

Re: Нет соединения с MySQL.

А ведь правда, у меня тут где-то недавно промелькнуло, стоял скиппинг на network`e .

П.С.:Пишет нету такого файла (my.cnf), у меня MOPSlinux 6.2, где он может быть?

mysql_user ()
Ответ на: Re: Нет соединения с MySQL. от mysql_user

Re: Нет соединения с MySQL.

MOPSLinux не пробовал
Когда я себя запускаю mysqld --help --verbose оно пишет:
...
Default options are read from the following files in the given order:
/etc/my.cnf /etc/mysql/my.cnf /usr/local/mysql/etc/my.cnf ~/.my.cnf
..
попробуй их там поискать или хотяб найти mysqld и --help --verbose узнать...

gods-little-toy ★★★ ()

Re: Нет соединения с MySQL.

> После чего пробую коннектиться к БД через разные менеджеры

итак, показываем: ps uax | grep mysqld

а также делаем mysql -u root -p, вводим пароль и показываем результат.

Komintern ★★★★★ ()
Ответ на: Re: Нет соединения с MySQL. от Komintern

Re: Нет соединения с MySQL.

Спасибо, попробовал команду --help --verbose, но пути не подошли.Попробовал по поиску найти файл.Он нашёлся только в /usr/bin/mysql5/my.cnf , однако я не уверен, что это от слаковского пакета конфиг, я просто еще до этого пробовал ставить мускуль из изходников, а по время установки слаковского мускуля, я не видел куда он устанавливался. Про процессы: Вот вывод команды, но перед включением мускуля: root 25460 0.0 0.1 2124 728 pts/0 D+ 06:26 0:00 grep mysqld Теперь вывод ps uax | grep mysqld, но уже с включенным: root 25719 0.2 0.2 2804 1396 pts/1 S 06:27 0:00 /bin/sh /usr/bin/mysqld_safe --datadir=/var/lib/mysql --pid-file=/var/run/mysql/mysql.pid --skip-networking mysql 25744 0.8 2.7 101064 13780 pts/1 Sl 06:27 0:00 /usr/libexec/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysql/mysql.pid --skip-external-locking --skip-networking root 25775 0.0 0.1 2300 868 pts/0 S+ 06:27 0:00 grep mysqld

Вот кстати здесь, оказывается, я и видел скиппинг на network`e.

mysql_user ()
Ответ на: Re: Нет соединения с MySQL. от mysql_user

Re: Нет соединения с MySQL.

UPD: В общем я поспрашивал, по вашим советам, как сделать чтобы мускуль в сеть "смотрел", мне посоветовали закомментировать строку SKIP="--skip-networking" в /etc/rc.d/rc.mysqld После чего я могу подключаться к БД Навикатом.Только я до конца еще не уверен, всё ли правильно...

mysql_user ()

Re: Нет соединения с MySQL.

1. cat my.cnf | grep skip-networking

2. по умолчанию, доступ только для пользователя root с localhost. поправь таблицу mysql.user и, если, плевать на безопасность замени хост на % дабы не морочиться.

Anoxemian ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.