LINUX.ORG.RU

Проблема с установкой i386 пакетов Debian lenny amd64


0

0

yuriy@debian-amd64:~/soft/fah$ sudo dpkg -i /home/yuriy/Downloads/soft/skype-debian_2.0.0.72-1_i386.deb
dpkg: error processing /home/yuriy/Downloads/soft/skype-debian_2.0.0.72-1_i386.deb (--install):
package architecture (i386) does not match system (amd64)
Errors were encountered while processing:
/home/yuriy/Downloads/soft/skype-debian_2.0.0.72-1_i386.deb

хотя есть папка /lib32. ЧЯДНТ?

Re: Проблема с установкой i386 пакетов Debian lenny amd64

Посмотри здесь
http://en.kioskea.net/faq/sujet-808-debian-debian-gnu-linux-4-0-amd64-install...

Downloading Skype

mkdir /home/lami20j/src
cd /home/lami20j/src
wget http://www.skype.com/go/getskype-linux-deb</code>;

Installation


As root:

su
apt-get install ia32-libs libasound2-plugins
dpkg -i --force-architecture skype_debian-1.3.0.53-1_i386.deb
exit



Configuring Skype


As user:

mkdir /home/lami20j/.lib32
dpkg-deb -x libqt3-mt_3.3.7-4_i386.deb /home/lami20j/.lib32/
cp -vR /home/lami20j/.lib32/usr/lib/* /home/lami20j/.lib32/
echo 'export LD_LIBRARY_PATH="/home/lami20j/.lib32"' >> /home/lami20j/.bashrc
source /home/lami20j/.bashrc







You can replace lami20j with your username.

Repeat procedure if you want to change the directory /home/lami20j/src, you can select the directory name that you prefer.

Bod ★★★★ ()

Re: Проблема с установкой i386 пакетов Debian lenny amd64

омг сколько плясок с бубном ради этого говнищща...

isden ★★★★★ ()

Re: Проблема с установкой i386 пакетов Debian lenny amd64

> skype: error while loading shared libraries: libQtDBus.so.4: cannot open shared object file: No such file or directory

Вот еще совет. Пишут, что работает 100%
------------------
Для начала качаем skype
Код
wget -c http://www.skype.com/go/getskype-linux-debian

От рута распаковываем его
Код
dpkg -x skype-debian_2.0.0.72-1_i386.deb /

Далее качаем эти библиотеки
Код
libglib2.0-0_2.16.6-1_i386.deb
libpcre3_7.8-2_i386.deb
libqt4-dbus_4.4.3-2_i386.deb
libqt4-network_4.4.3-2_i386.deb
libqt4-xml_4.4.3-2_i386.deb
libqtcore4_4.4.3-2_i386.deb
libqtgui4_4.4.3-2_i386.deb

Я качал их отсюда http://ftp.de.debian.org/ из сида брать лучше всего
Распаковываем из по одной в какую нибудь директорию и просто потом от рута копируем.
Код
paints:/home/sashka/skype# cp -a /tmp/usr/lib/* /usr/lib32/
--------------------------------------------

Bod ★★★★ ()

Re: Проблема с установкой i386 пакетов Debian lenny amd64

решено установкой ia32-libs-gtk, которій среди прочего установил

/emul/ia32-linux/usr/lib/qt4
/emul/ia32-linux/usr/lib/qt4/plugins
/emul/ia32-linux/usr/lib/qt4/plugins/imageformats
/emul/ia32-linux/usr/lib/qt4/plugins/imageformats/libqtiff.so
/emul/ia32-linux/usr/lib/qt4/plugins/imageformats/libqgif.so
/emul/ia32-linux/usr/lib/qt4/plugins/imageformats/libqmng.so
/emul/ia32-linux/usr/lib/qt4/plugins/imageformats/libqjpeg.so
/emul/ia32-linux/usr/lib/qt4/plugins/imageformats/libqico.so
/emul/ia32-linux/usr/lib/qt4/plugins/script
/emul/ia32-linux/usr/lib/qt4/plugins/script/libqtscriptdbus.so
/emul/ia32-linux/usr/lib/qt4/plugins/codecs
/emul/ia32-linux/usr/lib/qt4/plugins/codecs/libqtwcodecs.so
/emul/ia32-linux/usr/lib/qt4/plugins/codecs/libqcncodecs.so
/emul/ia32-linux/usr/lib/qt4/plugins/codecs/libqkrcodecs.so
/emul/ia32-linux/usr/lib/qt4/plugins/codecs/libqjpcodecs.so
/emul/ia32-linux/usr/lib/qt4/plugins/accessible
/emul/ia32-linux/usr/lib/qt4/plugins/accessible/libqtaccessiblewidgets.so
/emul/ia32-linux/usr/lib/qt4/plugins/inputmethods
/emul/ia32-linux/usr/lib/qt4/plugins/inputmethods/libqimsw-multi.s

oвсем спасибо за помощь

yurikoles ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.