LINUX.ORG.RU

Не устанавливаются TTF шрифты в ASPLinux 9 Кривой дистрибутив или кривые руки? Помогите!


0

0

Делаю все следующим образом: 1. Создаю дирикторию в каталоге /usr/X11R6/lib/X11/ 2. Делаю ссылку #ln -s ../encodings/encodings.dir /usr/X11R6/lib/X11/myttf/encodings.dir 3. Даю команду ttmkfdir -o fonts.dir 4. Даю команду cp fonts.dir fonts.scale 5. Потом chkfontpath --add /usr/X11R6/lib/X11/fonts/myttf/ 6. service xfs restart 7. Перезагружаюсь. Загружаю KDE и Центре управления в разделе шрифтов в списке не вижу ни одного нового шрифта!!! Их видит только OpenOffice да и то отображает не как Windows а как то более жирновато и коряво. Причем в конфигах /etc/X11/fs/config, /etc/X11/XftConfig -> /etc/fonts/fonts.conf все настройки и пути обновлены! Система не ругалась и все делала нормально, но шрифтов ни в гноме ни в кде не видать :( В чем может быть дело? Как заставить их работать?

anonymous

Re: Не устанавливаются TTF шрифты в ASPLinux 9 Кривой дистрибутив или кривые руки? Помогите!

pfgecnb xfontsel и посмотри есть ли они там, а в КДЕ попробуй поизвращатся с qtconfig

Delay ★★ ()

Re: Не устанавливаются TTF шрифты в ASPLinux 9 Кривой дистрибутив или кривые руки? Помогите!

Delay: pfgecnb вообще не знаю что такое, нет такой команды или файла, в xfontsel шрифты есть, в qtconfig не было, а в qtconfig3 появились как то странно..... Вобщем шрифты в КДЕ появились, но почеиу то если я выбираю этот шрифт - то квадратики.. :( Еще одна напасть! Как сделать чтобы все работало ПО ЧЕЛОВЕЧЕСКИ? В АСП 7.3. все по вышеуказанным мной инструкциям в первом сообщении все работало хорошо.

anonymous ()

Re: Не устанавливаются TTF шрифты в ASPLinux 9 Кривой дистрибутив или кривые руки? Помогите!

fcpackage стоит?
КДЕ жрет шрифты от xft2.
От xft 1 шрифты кушает gtk1, например.

Теперь о простом и вечном.
Ссылку на encodings создавать не нужно - все прекрасно (и главное
дело давно) работает и так.
xft тоже запускать не обязательно - ты же не шаришь фонты по сетке?

Главное - проверь наличие строчки
Load "freetype"
в своем XF86Config-4 (раздел Module).

У меня была другая проблема - шрифты после распаковки выглядели вот так: ARIAL.TTF
ttmkfdir их жрала и прекрасно прописывала кодировки, но ни одна программа их не видела - стоило переименовать в нижний регистр и все
заработало.

Что касается квадратов - а шрифты юникодные? (iso10646-1)

P.S. XFTConfig is obsolette.

jackill ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.