LINUX.ORG.RU

alsa, не хочет стартовать при старте системы


0

0

сабж
не сильно силен в линухе, но заметил что при старте системы у меня не создаеться устройтсво /dev/dsp -> /dev/dsp0
пробылвал
#rmmod snd_hda_intel, snd_timer ... snd
#modprobe snd_hda_intel ....
#alsaconf

но не помогает
что помогает:
#dpkg-reconfigure alsa-base
создает устройство /dev/dsp потом через rexima настаиваю громкость
только не всегда удобно это делать ((

хотело бы услышать ваш совет,
какой скрипт при старте должен создавать /dev/dsp и в чем собственно может быть проблемма..

и если нужно - какие данные еще необходимо предоставить
(ps в dmesg - пусто, а sh /etc/init.d/alsa start просто говорит что у вас нет звуковых карт)

спасибо за ответы.

anonymous

Re: alsa, не хочет стартовать при старте системы

При подобных вопросах, нужно писать, какой у вас дистрибутив.

ierton ★★ ()

Re: alsa, не хочет стартовать при старте системы

Я так думаю lsmod и пересобрать ядро с твоей карточкой, или грузить модуль при старте вроде /etc/modprobe.conf|/etc/modules.conf.

paranormal ★★ ()

Re: alsa, не хочет стартовать при старте системы

сравни вывод lsmod до и после "dpkg-reconfigure alsa-base" пробуй загружать эти модули modprobe`ом. Если всё заработает то запихни их /etc/modules.conf чтобы они грузились при старте системы. (Возможно ошибаюсь с файлом. если что погугли про debian etch autoload modules)

Nao ★★★★★ ()

Re: alsa, не хочет стартовать при старте системы

мне помогло alsaconf хоть и говорят что alsaconf deprecated , но работает
иногда ...

j262 ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.