LINUX.ORG.RU

Помогите восстановить линукс


0

0

Проблема в том что после неудачной перекомпиляции ядра полетел раздел /boot теперь там ничего нет, в следствии чего линукс не загружается.. после этого переставлялася винХР, тоесть при включении компьютера загружается именно он, имеется ввиду что ни Grub'а ни Лило нету..
имеется линукс native большой (18гб) раздел, в нем же лежит дистрибутив Master2,
/boot раздел (100мб) пустой (форматированный),
swap раздел (130мб) пустой (форматированный,
NTFS раздел (20гб),
имеется также загрузочная дискета для Линукса, которая позволяет загрузиться по rescue, использовав дистрибутив мастера на жестком диске, или запустить инсталятор мастера2 с того же диска..
на компашках дестрибутива !нету, только в этом разделе на жестком диске..
имеется также пишущий сидюк который работает под виндами..

запуск инсталлятора с жёсткого ничего не даёт, так как при разбиении дисков вылетает по ошибке при форматировании /boot раздела и Swap'а, (корневой раздел форматировать не хочется так как на нем находится дистрибутив)
как подсказывает мне логика, для того чтобы мочь загружаться с линукса надо записать vmlinuz (и еще чтото?) в /boot и установить Lilo/grub.. либо же настроить ХРшный загрузчик... но как добится этого ?
помогите вечномногомноюуважаемые ГУРУ! ;((

anonymous

Re: Помогите восстановить линукс

Давно не в линуксе (в bsd), но раз никто не берется помочь, подскажу,
как помню.


Если у тебя запускается инсталлятор, попробуй выйти на 4-ю виртуальную
консоль (Alt+F4). Файловая система, которую ты увидишь, не твоя -
настоящая, а та, что инсталлятор с собой таскает. Попробуй
подмонтировать в /tmp, только каталог свой там создай (только /tmp
доступен для записи, остальные - для чтения) свой раздел (mount
/dev/hda_your_root_partition /tmp/la_la_la). Создай еще один каталог в
/tmp, подмонтируй туда свой /boot. Если опять выдаст ошибку -
переформатируй бут (mkext2fs <имя_раздела>, кажется) и подмонтируй.
Если ты компилировал сырцы, у тебя должна остаться копия ядра в дереве
исходников (linux/что-то_еще/bzimage или что-то в этом роде). Скопируй
ее туда, куда ты подмонтировал /boot. Надеюсь твое ядро рабочее.
Посмотри параметры к lilo, может удастся его запустить (только конфы
укажи его родные в /tmp/la_la_la/etc/lilo.conf).
На днях посмотрю конкретнее.
А мож тебе ядро на мыло выслать ? :-)))

random ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.