LINUX.ORG.RU

mplayer


0

0

стоит redhat 7.3 поставил mplayer из rpm

mplayer-090pre9-1.i686.rpm mplayer-common-090pre9-1.i686.rpm mplayer-font-koi8r-1.0-1.noarch.rpm mplayer-gui-0.90pre9-1.i686.rpm mplayer-skin-default-1.5-1.noarch.rpm при запуске выдает: can't load font:/usr/share/mplayer/font/font.desc как с этим бороться?


Re: mplayer

Для начала зайди туда и посмотри - есть ли у тебя такой файл.
Скорее всего нет.
Заходишь в эту директорию или $HOME/.mplayer
создаешь директорию font.arpi_osd_a.raw
Вот такие файлики у меня там лежат:
arpi_osd_b.raw
font.desc
koi8-r-a.raw
koi8-r-b.raw
osd-mplayer-a.raw
osd-mplayer-b.raw
test.sub

osd есть сделанные по умолчанию, но что-то у меня они ужасно
работали, поэтому я накопал в исходниках диреторию tools,
взял оттуда директорию subfont-c, скомпилил,
сказал фонты с iso8859-1 и взял оттуда скрипт runme, поправил
пути и кодировку и запустил.
Получил font.desc и koi8-r-a, koi8-r-b нормальные.

А вот работают они или нет - проверяешь с помощью test.sub

Можно так не е...ться - если у тебя стоит freetype >=2.0.9
можешь скомпилить с поддержкой фритайп, после чего
на любой юникодный фонт делаешь симлинк под названием
subfont.ttf в своей директории $HOME/.mplayer
и ставишь в gui.conf следующие строчки
osd_level = 2 (ну это по вкусу - ничего, только полосы прокрутки, значки и полосы)
sub_auto_load = 1
sub_unicode = 0 (а не в unicode ли у нас вывод - не в уникоде)
sub_pos = 100 (хз)
font_factor = 0.750000
font_name = "~/.mplayer/font/font.desc" (твой путь)
font_encoding = "cp1251" (кодировка субтитров)
font_text_scale = 2.000000 (масштаб текста)
font_osd_scale = 4.000000 ( масштаб значков)
font_blur = 0.000001 (размытие?)
font_outline = 0.000001 (хз)
font_autoscale = 3 (хз, как понимаю, для полноэкранного режима)

Остается другой момент - кроме sub (microdvd) ничего не жрется.
scr опознается, но на экран упорно не выводится (хотя опция перекодировки
есть).

jackill ★★★★★ ()

Re: mplayer

такой то файл там есть еще есть koi8-r-a.raw и koi8-r-b.raw и все. никаких osd-mplayer-a.raw и osd-mplayer-b.raw и т.д. там нет я думаю может еще какой пакет поставить надо? или это просто баг последней сборки этих пакетов

по поводу сборки из исходников обычно так и делаю но уж очень захотелось из rpm попробовать поставить чтоб менеджер пакетов знал что у меня стоит

wand ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.