LINUX.ORG.RU

Проблема с захватом звука с tv-тюнера


0

0

Соответственно загружается модуль btaudio insmod btaudio analog=1 debug=1

>btaudio: driver version 0.7 loaded [analog] >PCI: Found IRQ 12 for device 00:0b.1 >PCI: Sharing IRQ 12 with 00:0b.0 >btaudio: Bt878 (rev 17) at 00:0b.1, irq: 12, latency: 32, mmio: 0xd9002000 >btaudio: registered device dsp1 [analog] >btaudio: registered device mixer1

Далее, пытаемся записать звук sox -w -r 32000 -t ossdsp /dev/dsp1 -t .dat a.txt Опять никаких ошибок, однако когда открываем a.txt, то видим постоянный сигнал: ; Sample Rate 32000 0 0.99996948 3.125e-05 0.99996948 6.25e-05 0.99996948 9.375e-05 0.99996948 0.000125 0.99996948 В чём могут быть грабли?

anonymous

Re: Проблема с захватом звука с tv-тюнера

Соответственно загружается модуль btaudio
insmod btaudio analog=1 debug=1

>btaudio: driver version 0.7 loaded [analog]
>PCI: Found IRQ 12 for device 00:0b.1
>PCI: Sharing IRQ 12 with 00:0b.0
>btaudio: Bt878 (rev 17) at 00:0b.1, irq: 12, latency: 32, mmio: 0xd9002000
>btaudio: registered device dsp1 [analog]
>btaudio: registered device mixer1

Далее, пытаемся записать звук
sox -w -r 32000 -t ossdsp /dev/dsp1 -t .dat a.txt
Опять никаких ошибок, однако когда открываем a.txt, то видим постоянный сигнал:
; Sample Rate 32000
0 0.99996948
3.125e-05 0.99996948
6.25e-05 0.99996948
9.375e-05 0.99996948
0.000125 0.99996948
В чём могут быть грабли?

anonymous
()

Re: Проблема с захватом звука с tv-тюнера

у меня почти такиеже траблы но правда с видео
когда пытаюсь что-нить закапчурить использую mencoder :
mencoder -v -tv on:driver=v4l:width=640:height=480 -ovc lavc -lavcopts vcodec=mpeg1video:vbitrate=900 -oac mp3lame -lameopts cbr:br=64:vol=9 -o test.avi
но звука в фильме нет хотя mplayer говорит :
Detected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, sfmt: 0x10 (2 bps), ratio: 8000->176400 (64.0 kbit)

а когда пытаюсь явно указать audio-девайс , то получаю :
mencoder -v -tv on:driver=v4l:width=640:height=480:adevice=/dev/sound/dsp3 -ovc lavc -lavcopts vcodec=mpeg1video:vbitrate=900 -oac mp3lame -lameopts cbr:br=64:vol=9 -o test.avi

Video capture card reports the audio setup as follows:
  0: TV: muted=no volume=0 bass=0 treble=0 balance=0 mode=mono
 channels: 1
ioctl dsp getfmt: 0
Supported formats: 50
ioctl dsp setfmt: 0
ioctl dsp stereo: 0 (req: 0)
ioctl dsp speed: 0
ioctl dsp trigger: -1
trigger: af00
ioctl dsp trigger: -1
Unable to set trigger: 1
Cannot open demuxer
Exiting...

borisych ★★★★★
()

Re: Проблема с захватом звука с tv-тюнера

терь все в порядке в pre9 пофиксили ...

borisych ★★★★★
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.