LINUX.ORG.RU

чё-то не то с жёстким диском


0

0

стояли 3 диска, все однотипные seagate, только разного объёма 200, 200 и 300, все работают замечательно, поставил ещё один такой же, но на 500 и он дико тормозит, очень дико

hdparm:
/dev/hdd:
multcount = 0 (off)
IO_support = 3 (32-bit w/sync)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 60801/255/63, sectors = 976773168, start = 0

что можно с этим сделать?

anonymous

Re: чё-то не то с жёстким диском

Поиграть с опциями -m (multicount, попробуй 16 или даже 32, если поддерживается), -X (установка режима udma5 или udma6, если есть)

gruy ★★★★★ ()

Re: чё-то не то с жёстким диском

Что говорит по поводу этого диска hdparm -tT ?

> multcount = 0 (off) 

multcount     = 16 (on)

Опция hdparm  - -m 16

> readahead = 8 (on) 

 readahead     = 256 (on)

Опция hdparm -  -a 256

> IO_support = 3 (32-bit w/sync) 

А-а-а-а.

 IO_support    =  0 (default 16-bit)

Опция hdparm - -c0

Если заведется - будет быстрее.

anonymous ()
Ответ на: Re: чё-то не то с жёстким диском от anonymous

Re: чё-то не то с жёстким диском

/dev/hdd:
multcount = 16 (on)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 60801/255/63, sectors = 976773168, start = 0

всё тоже самое
с дисками меньшего объёма таких проблем не было

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.